Notification

Icon
Error

LsAgent for Windows

Posted: Thursday, September 13, 2018 12:46:07 PM(UTC)
Esben.D

Esben.D

Member Administration Original PosterPosts: 1,683
3
Like
This deployment package can be used to silently deploy the new LsAgent to assets in your network.

To ensure you can use this package, you must meet the following requirements:
To deploy the package, do the following:
  • Download the Windows installer from https://www.lansweeper.com/download/lsagent/
  • Put the installer in the following directory: Program Files (x86)\Lansweeper\PackageShare\Installers
  • Modify package step 1 and add the FQDN, NetBIOS or IP of your scanning server for a direct server connection. Add the your unique LsAgent key which can be found in Scanning\Cloud Relay Configuration for using the relay.
LsAgent will first try a direct server connection. Should it fail, it will use the relay to get the information to Lansweeper. Optionally, you can modify the package to use either direct server connection only or relay server only by removing the parameter of the connection type you do not want to use.

Here is an overview of all parameters available for the LsAgent installer:
UserPostedImage
LsAgent for WindowsDownload Package
DescriptionSilently install LsAgent for Windows.

1. Download the Windows installer from https://www.lansweeper.com/download/lsagent/ or find it in the Client folder of your scanning server installation
2. Put the installer in the following directory: Program Files (x86)\Lansweeper\PackageShare\Installers
3. Modify package step 1 and add the FQDN, NetBIOS or IP of your scanning server for a direct server connection. Add the your unique LsAgent key which can be found in Scanning\Cloud Relay Configuration for using the relay.
Final ActionNothing
Max. Duration15 min(s), 0 hour(s)
RescanNo
Steps
1. Check for LsAgent installer
TypeCondition
SuccessGo To Next
FailureStop (Failure)
Conditions
File {PackageShare}\Installers LsAgent-windows.exe Exists
2. Install LsAgent
TypeInstaller
Return Codes 0,1641,3010
SuccessStop (Success)
FailureStop (Failure)
Command "{PackageShare}\Installers\LsAgent-windows.exe" --mode unattended --server --agentkey
fpd2dc
#1fpd2dc Member Posts: 9  
posted: 9/27/2018 2:45:50 PM(UTC)
I tried running the installer package and got the following error
Result: Deployment ended: Incorrect function. Stop(Failure). Credential: (XXXXXXXXXXXXXXXX). ShareCredential: (xxxxxxxx). Command: "\\XXXXXXXXXX\DefaultPackageShare$\Installers\LsAgent-windows.exe" --mode unattended --server xx.xx.xx.47 --agentkey xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxf9864\

Any idea where to look to fix this issue, I modified the items in package.

Thanks
Bruce
Esben.D
#2Esben.D Member Administration Original PosterPosts: 1,683  
posted: 9/28/2018 1:41:16 PM(UTC)
Originally Posted by: fpd2dc Go to Quoted Post
Deployment ended: Incorrect function. Stop(Failure). Credential: (XXXXXXXXXXXXXXXX). ShareCredential: (xxxxxxxx). Command: "\\XXXXXXXXXX\DefaultPackageShare$\Installers\LsAgent-windows.exe" --mode unattended --server xx.xx.xx.47 --agentkey xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxf9864\


I would double-check that you agent key was entered correctly (the \ seems wierd, unless that is only part of the error message)

Aside from that, double check your exe file is in the folder which is mentioned and with the exact same file name.

fpd2dc
#3fpd2dc Member Posts: 9  
posted: 9/28/2018 2:59:19 PM(UTC)
Charles
The error message is copied out of the deployment page of LS.
the XXx's are only part of that field as to hide them.

I tried with out the agent key to see if that works, and same message. See I this screen capture helps
fpd2dc attached the following image(s):
lsagent log.PNG
Esben.D
#4Esben.D Member Administration Original PosterPosts: 1,683  
posted: 10/4/2018 4:10:03 PM(UTC)
I've updated the package to include a check that the file can be found.

For your issue, I would recommend testing the install command locally on a machine as a test:

  • Copy the Result command of the failed deployment package.
  • Use the exact path defined under Deployment\Security options.
  • Paste the command into the command prompt of a machine where the deployment failed.
  • This should help you identify the cause of the issue. Only when the command works in Command Prompt will it work in Lansweeper as well.
  • If the command worked then we recommend that you check that the command has been added correctly to your package and the parameter are also correctly added to the parameter field.
If a step works in the Command Prompt, it should work in the deployment package.

If your issue persists, its best to contact our support team.
fpd2dc
#5fpd2dc Member Posts: 9  
posted: 10/5/2018 8:24:59 PM(UTC)
I found a couple of mistakes i made and got locally to come up to i stall prompr. I then got it to deploy on that same pc from the consoles.

Waiting to see now ifscheduled pc's deployed overnight.
Roger Mihalko
#6Roger Mihalko Member Posts: 2  
posted: 10/11/2018 6:57:23 PM(UTC)
"{PackageShare}\DefaultPackageShare$\Installers\LsAgent-windows.exe"--mode unattended --server it-lansweeper --agentkey xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxc9a29

Result: Deployment ended: Incorrect function. Stop(Failure). Credential: (xxx). ShareCredential: (xxx).
Command: "\\it-lansweeper\DefaultPackageShare$\DefaultPackageShare$\Installers\LsAgent-windows.exe"--mode unattended --server it-lansweeper --agentkey xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxc9a29



I keep getting the incorrect function error also.


when I run the base command it pops up the agent screen so I know it can find the file. --Mode and beyond dont work at all.


any ideas?
Rudamento
#7Rudamento Member Posts: 10  
posted: 10/12/2018 6:25:31 PM(UTC)
Originally Posted by: Roger Mihalko Go to Quoted Post
"{PackageShare}\DefaultPackageShare$\Installers\LsAgent-windows.exe"--mode unattended --server it-lansweeper --agentkey xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxc9a29

Result: Deployment ended: Incorrect function. Stop(Failure). Credential: (xxx). ShareCredential: (xxx).
Command: "\\it-lansweeper\DefaultPackageShare$\DefaultPackageShare$\Installers\LsAgent-windows.exe"--mode unattended --server it-lansweeper --agentkey xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxc9a29



I keep getting the incorrect function error also.


when I run the base command it pops up the agent screen so I know it can find the file. --Mode and beyond dont work at all.


any ideas?


Try removing the "-" from your key. That was preventing us from using it. Didn't even notice the "-" for a while.
Roger Mihalko
#8Roger Mihalko Member Posts: 2  
posted: 10/12/2018 6:49:59 PM(UTC)
it failed with incorrect function with that change. thanks for trying.

10/12/2018 12:47:28 PB-MXL7253FKY LsAgent for Windows Roger S. Mihalko 1 2 System Account Result: Deployment ended: Incorrect function. Stop(Failure). Credential: (x). ShareCredential: (x).
Command: "\\it-lansweeper\DefaultPackageShare$\Installers\LsAgent-windows.exe" --mode unattended --server it-lansweeper --agentkey xxxxxxxxxxxxxxxxxxxxxxxxxxxxx 6.0.230.4
Esben.D
#9Esben.D Member Administration Original PosterPosts: 1,683  
posted: 10/22/2018 3:27:50 PM(UTC)
If you do get stuck trying to deploy LsAgent, it's bet you contact our support team for technical support.
kelloggfan
#10kelloggfan Member Posts: 1  
posted: 10/24/2018 9:12:26 PM(UTC)
what did I miss? where do you put the edited XML file? in the same folder as the install file?
David Goodwin
#11David Goodwin Member Posts: 3  
posted: 12/20/2018 2:24:19 PM(UTC)
We found on some machines that if .NET was not installed (or somehow broken) it caused installation issues. Odd that a couple of our machines did not have a decent version installed. We do still occasionally see a few incorrect functions.

Used NDP472-KB4054530-x86-x64-AllOS-ENU.exe and rebooted the machines before deploying LSAgent.

Maybe it will help some since the silent agent install does not check/install .NET before installation.
DJSMC
#12DJSMC Member Posts: 1  
posted: 5/1/2019 1:27:09 PM(UTC)
Yes where do you put the XML file? No instructions on what to do with it other that to edit the FQDN and cloud relay!!!

Active Discussions

Lansweeper How to modify scan schedule for multiple scanning targets?
by  aturkovich   Go to last post Go to first unread
Last post: Yesterday at 3:46:04 PM(UTC)
Lansweeper Changing/Editing tblComputerSystem.DomainRole
by  Esben.D  
Go to last post Go to first unread
Last post: Yesterday at 2:41:17 PM(UTC)
Lansweeper Version Check Page
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 2:37:43 PM(UTC)
Lansweeper warranty information missing
by  Esben.D  
Go to last post Go to first unread
Last post: Yesterday at 2:33:03 PM(UTC)
Lansweeper Dell Switch Servicetag
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 2:12:22 PM(UTC)
Lansweeper Office 365 ProPlus not detected in a few PCs
by  Esben.D  
Go to last post Go to first unread
Last post: Yesterday at 2:10:44 PM(UTC)
Lansweeper Imageright Installation
by  CyberCitizen   Go to last post Go to first unread
Last post: Yesterday at 1:01:30 AM(UTC)
Lansweeper Is the conditional step for OS arch broken?
by  CyberCitizen  
Go to last post Go to first unread
Last post: Yesterday at 1:00:54 AM(UTC)