Notification

Icon
Error

BHO with apostrophe

Posted: Monday, September 23, 2019 5:24:34 PM(UTC)
Randomusername

Randomusername

Member Original PosterPosts: 7
0
Like
https://social.technet.m...heck?forum=winserver8gen

To start, I know that Virtual Storage Mount Notification {3532036A-BE08-43DC-9444-53022089DD96} is a valid BHO.

However, I have the BHO listed as {3532036A-BE08-43DC-9444-53022089DD96}' (with the ' at the end), which is located at HKLM\Software|Wow6432Node\Microsoft\windows\current version\explorer\BHO . In it, there is a default with its name and another entry that states Nointernetexplorer 1.

Is this a valid BHO?
Randomusername attached the following image(s):
C1apture.PNG
Esben.D
#1Esben.D Member Administration Posts: 1,933  
posted: 9/24/2019 4:00:10 PM(UTC)
I checked and you can enter it into Lansweeper's registry scanning, so I presume it will scan just fine.
Randomusername
#2Randomusername Member Original PosterPosts: 7  
posted: 9/24/2019 4:06:21 PM(UTC)
Originally Posted by: Esben.D Go to Quoted Post
I checked and you can enter it into Lansweeper's registry scanning, so I presume it will scan just fine.


I had sent an email to the company that I believed made it. They replied today with:

Quote:
Thank you for contacting us. I am not sure that I interpret your question right. The BHO is identified using it's GUID, which starts with { and ends with } . I don't know where the apostrophe comes from and where you see it. The apostrophe does not make the BHO invalid, though depending on where it is present, such apostrophe can prevent the BHO from being loaded.

On the other hand, this BHO is old and the recent versions of our products don't install or use it.


I removed the BHO from the registry and the server is working fine. Plus, I no longer get the unauthorized BHO.

Also, do you think Daves replies on technet were pointless as well? I honestly don't understand why people reply there when they have no answer.
Esben.D
#3Esben.D Member Administration Posts: 1,933  
posted: 9/24/2019 4:21:54 PM(UTC)
I had to refresh my own memory by looking it up. The Lansweeper report basically just checks whether the BHO is added to the list of approved ones in software authorization. This means it is up to the user to decide whether they are valid or not.

But it does indeed seem odd to have an apostrophe at the end. Maybe at some point edited the name and missed his enter key or something.

Also, people on the internet can get defensive really quickly, there is no point in arguing that he should have read your question properly, usually they don't change their mind anyway Brick wall

Active Discussions

Lansweeper Hyper-V guests dissapeared and reappeared
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:30:47 PM(UTC)
Lansweeper DB cleanup script
by  William382  
Go to last post Go to first unread
Last post: Yesterday at 4:23:43 PM(UTC)
Lansweeper Installing MS KB with Deploy
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:01:45 PM(UTC)
Lansweeper Ticket Info Meter incorrect
by  pfalls  
Go to last post Go to first unread
Last post: Yesterday at 3:27:44 PM(UTC)
Lansweeper Asset Checkboxes in reports
by  ufficioced   Go to last post Go to first unread
Last post: Yesterday at 1:22:17 PM(UTC)
Lansweeper Silent "Run as logged in user" option
by  CyberCitizen  
Go to last post Go to first unread
Last post: Yesterday at 3:45:25 AM(UTC)
Lansweeper New ticket creation not emailing the user
by  MVMIC IT LANSWEEPER   Go to last post Go to first unread
Last post: 11/15/2019 5:36:23 PM(UTC)