Notification

Icon
Error

check if process is running report

Posted: Thursday, August 22, 2019 7:37:51 PM(UTC)
Randomusername

Randomusername

Member Original PosterPosts: 7
0
Like
I couldn't find it anywhere on here.

I need a report that scans one server and checks if a process is not running.

ex.,

ServerA needs explorer.exe to be running in the task manager. The report should populate that ServerA does not have explorer.exe running. If explorer.exe is running, the report should have no result.

Is this something lansweeper is capable of and if yes, can someone assist me with it?

I tried below but it claims assetname is an invalid column.


Select tblAssets.AssetName, tblProcesses.Caption
where tblAssets.AssetName = 'Server' AND tblProcesses.Caption = 'Process.exe'
Randomusername
#1Randomusername Member Original PosterPosts: 7  
posted: 8/22/2019 8:00:49 PM(UTC)
I figured out the issue. I had to select the names from the search box. For whatever reason, it didn't like them typed.


Select Top 1000 tblAssets.AssetName,
tblProcesses.Caption
From tblAssets
Inner Join tblProcesses On tblAssets.AssetID = tblProcesses.AssetID
Where tblAssets.AssetName = 'Server' And tblProcesses.Caption =
'Process.exe'


I need this to follow what I wrote above. To be blank if true and populate if false. This is so I can setup an email alert when it is false.
Randomusername
#2Randomusername Member Original PosterPosts: 7  
posted: 8/23/2019 3:29:16 PM(UTC)
Well, I tried <> and that just shows all processes other than the one I want.

I ended up just saving this report as a chart for now and placing it on the main page.

Hopefully, someone will eventually be able to assist me in making the report do what I need.

Active Discussions

Action PowerShell - Top 10 Memory Hogs
by  iamBaphomet   Go to last post Go to first unread
Last post: Yesterday at 3:00:53 PM(UTC)
Lansweeper Launch TeamViewer from inside LanSweeper
by  CyberCitizen  
Go to last post Go to first unread
Last post: 2/19/2020 12:16:12 AM(UTC)
Action Email user
by  morpios   Go to last post Go to first unread
Last post: 1/26/2020 10:55:44 AM(UTC)
Action Psexec service delete
by  steveb  
Go to last post Go to first unread
Last post: 1/25/2020 12:15:01 AM(UTC)
Lansweeper Uninstall Software - Mozilla Firefox
by  Carl_Allen   Go to last post Go to first unread
Last post: 1/22/2020 10:44:36 AM(UTC)
Lansweeper Installation Parameters
by  PeterG  
Go to last post Go to first unread
Last post: 1/8/2020 10:11:51 PM(UTC)
Lansweeper embedded questions
by  mkergan   Go to last post Go to first unread
Last post: 12/20/2019 5:19:46 PM(UTC)
Lansweeper Result: Deployment ended: The environment is incorrect.
by  mkergan  
Go to last post Go to first unread
Last post: 12/19/2019 6:31:44 PM(UTC)