Notification

Icon
Error

Helpdesk API - Helpdesk API

Posted: Thursday, June 13, 2019 5:00:11 PM(UTC)
Shane Sanders

Shane Sanders

Member Original PosterPosts: 1
1
Like
Hello Everyone,
I have created a basic web form for my end users to create tickets with. See code below. I am trying to add multiple custom fields to this and find myself coming up short. If you have a working solution for this can you post or send me an email to ssanders@mdspn.com with your working code? Thanks in advance.

Code:
<form action="http://lansweeper/api.aspx?Action=AddTicket&Key=xxx" method="post">
  <div>
    <label for="subject">What trouble are you having?</label>
    <input name="subject" id="subject" value="">
  </div>
  <div>
    <label for="description">Please be descriptive?</label>
    <input name="description" id="description" value="">
  </div>
  <div>
    <label for="email">E-mail Address</label>
    <input name="email" id="email" value="ssanders@mdspn.com">
  </div>


  <div>
    <label for="customfields">IP Address</label>
    <input name="customfields" id="customfields" value="">
  </div>


  <div>
    <button>Submit</button>
  </div>
</form>
Skylar@Hennig
#1Skylar@Hennig Member Posts: 2  
posted: 10/27/2020 4:44:50 PM(UTC)
Hello,

did you ever get this working? I haven't been able to use the API to create tickets at all. even if I type in the URL per the documentation (http://lansweeper:81.api.aspx?Action=AddTicket&Key=123&Subject=Test&Description=TEst&username=test&email=test@tes.com) I get a server 500 error.
scoops98
#2scoops98 Member Posts: 2  
posted: 4/14/2021 11:53:30 AM(UTC)
I am trying to achieve the same thing. It looks like authentication has to happen via a browser before the API will work which doesnt make much sense.

Active Discussions

Lansweeper New ticket auto-assignment & default state
by  Brandon   Go to last post Go to first unread
Last post: Yesterday at 5:21:31 PM(UTC)
Lansweeper Automatic Follow-Up for Tickets
by  Francis Lee Mondia - Endace  
Go to last post Go to first unread
Last post: 5/12/2021 11:06:51 PM(UTC)
Lansweeper Can't see devices on Lansweeper
by  vqT4cDoP9iXyMZwoDUWU   Go to last post Go to first unread
Last post: 5/12/2021 8:33:21 PM(UTC)
Lansweeper LAPS managed password
by  SystemAdmin  
Go to last post Go to first unread
Last post: 5/12/2021 6:08:42 PM(UTC)
Lansweeper Install Adobe Reader Error
by  Brandon   Go to last post Go to first unread
Last post: 5/12/2021 2:46:54 PM(UTC)
Lansweeper Stop deployment
by  Tyler M.  
Go to last post Go to first unread
Last post: 5/12/2021 1:59:22 PM(UTC)
Lansweeper "Out of memory" in errorlog.txt
by  dua   Go to last post Go to first unread
Last post: 5/12/2021 1:00:42 PM(UTC)
Lansweeper Installation issues
by  Troy  
Go to last post Go to first unread
Last post: 5/12/2021 9:24:54 AM(UTC)