Notification

Icon
Error

Deploy a registry key

Posted: Friday, March 23, 2018 11:22:12 AM(UTC)
Esben.D

Esben.D

Member Administration Original PosterPosts: 2,186
3
Like
This is a short deployment package to deploy a .reg file containing one or multiple registry keys and rescan the asset after deployment.

Please note that you will have to generate this .reg file yourself first and place it in the {packageshare}\Registry folder. Should you have your .reg file in a different folder of the packageshare, you can modify the path in step 1.

Additionally, in this package they file is named Key.reg. Should your .reg file be name differently, you will have to modify step 1 to reflect this.
Deploy a registry keyDownload Package
Description1. Create a .reg file to use for deploying
2. Place the .reg file in the {packageshare}\Registry folder.
3. Double check that the path and file name in Step 1 are similar to the path and the file of your .reg file.
Final ActionNothing
Max. Duration5 min(s), 0 hour(s)
RescanYes
Steps
1. Deploy registry key
TypeCommand
Return Codes 0,1641,3010
SuccessStop (Success)
FailureStop (Failure)
Command regedit.exe /S {packageshare}\Registry\Key.reg
Rmon
#1Rmon Member Posts: 3  
posted: 10/28/2021 11:06:05 AM(UTC)
i tried to follow this step

i have my .reg file inside C:\Program Files (x86)\Lansweeper\PackageShare\Installers in my server

delnetworkdrives.reg
******
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Network]
******

and type: command
regedit.exe /S {packageshare}\Installers\delnetworkdrives.reg


Installer logs shows
Result: Deployment ended: The operation completed successfully. Stop(Success).

but drives still exist

If i manually execute the .reg its working properly
Mr Bass
#2Mr Bass Member Posts: 4  
posted: 10/29/2021 4:08:20 PM(UTC)
Originally Posted by: Rmon Go to Quoted Post
i tried to follow this step

i have my .reg file inside C:\Program Files (x86)\Lansweeper\PackageShare\Installers in my server

delnetworkdrives.reg
******
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Network]
******

and type: command
regedit.exe /S {packageshare}\Installers\delnetworkdrives.reg


Installer logs shows
Result: Deployment ended: The operation completed successfully. Stop(Success).

but drives still exist

If i manually execute the .reg its working properly


Never trust the logs, sometimes, they say my deploiment failed but actually worked fine, can't you do it using a .ps1 file or batch instead of .reg? (I mean, take a test to draw new conclusions), maybe it's lansweeper thing... cheers and good luck.
Rmon
#3Rmon Member Posts: 3  
posted: 10/30/2021 5:38:19 AM(UTC)
i tried to use

net use * /d /y

if manual it is working but via lansweeper type : command , it is not working
Don
#4Don Member Posts: 33  
posted: 3/23/2022 6:06:39 PM(UTC)
needs to be ran as the currently logged on user.. other users wont have access to remove drive mappings

Active Discussions

Lansweeper Lansweeper Dark Theme
by  mrobbins   Go to last post Go to first unread
Last post: Yesterday at 5:38:01 PM(UTC)
Lansweeper Detect Docking Stations
by  GlenH  
Go to last post Go to first unread
Last post: Yesterday at 3:52:13 PM(UTC)
Lansweeper Exclude non-windows assets from scanning by assetname
by  rapheren   Go to last post Go to first unread
Last post: Yesterday at 1:18:12 PM(UTC)
Lansweeper HTTPS Certifikate untrusted
by  pskup  
Go to last post Go to first unread
Last post: Yesterday at 9:20:07 AM(UTC)
Lansweeper Migrate to new host but without SQL
by  pskup   Go to last post Go to first unread
Last post: Yesterday at 9:03:14 AM(UTC)
Lansweeper Object reference error after updating to 10.2.0.0
by  Erik.T  
Go to last post Go to first unread
Last post: Yesterday at 8:10:25 AM(UTC)
Lansweeper Custom reporting - Asset Groups and AD Description
by  rbshawn   Go to last post Go to first unread
Last post: 6/29/2022 10:54:10 PM(UTC)
Lansweeper A FIX for an odd Scan Error WMI/DCOM from scanning server
by  danielm  
Go to last post Go to first unread
Last post: 6/29/2022 10:14:44 PM(UTC)