Notification

Icon
Error

LsAgent Reliability Problems

Posted: Friday, June 4, 2021 11:39:38 PM(UTC)
marck1024

marck1024

Member Original PosterPosts: 44
1
Like
If you run the report "LsAgent: Not seen in the last 7 days", and then the "Ping Assets" action, do you find any computers online? If the agent is working correctly, you shouldn't. But I have on multiple occasions.

I've encountered two different problems. On some of the computers, the Lansweeper Agent Service is simply not running. I looked in the event log for crashing, but the service did not crash. It either failed to start or gracefully exited. If I manually start it, the agent starts working.

On several others, I found a corrupt LsAgent.ini file. In all cases, the contents were gone, replaced by 279 blank spaces.

I sent both issues into support. Antivirus was initially blamed for the corrupt LsAgent.ini problem, but there is nothing on these systems other than the default Windows Defender.

It's disappointing that LsAgent is not more robust and reliable. It's main purpose is to allow scanning of systems that leave the corporate network. I was able to fix the systems I found when I checked the "LsAgent: Not seen in the last 7 days" report, but I don't know how many systems are out in the wild that are forever broken. This would be an awesome feature if I could count on it.
cjcox
#1cjcox Member Posts: 17  
posted: 6/11/2021 9:45:41 PM(UTC)
Originally Posted by: marck1024 Go to Quoted Post
If you run the report "LsAgent: Not seen in the last 7 days", and then the "Ping Assets" action, do you find any computers online? If the agent is working correctly, you shouldn't. But I have on multiple occasions.

I've encountered two different problems. On some of the computers, the Lansweeper Agent Service is simply not running. I looked in the event log for crashing, but the service did not crash. It either failed to start or gracefully exited. If I manually start it, the agent starts working.

On several others, I found a corrupt LsAgent.ini file. In all cases, the contents were gone, replaced by 279 blank spaces.

I sent both issues into support. Antivirus was initially blamed for the corrupt LsAgent.ini problem, but there is nothing on these systems other than the default Windows Defender.

It's disappointing that LsAgent is not more robust and reliable. It's main purpose is to allow scanning of systems that leave the corporate network. I was able to fix the systems I found when I checked the "LsAgent: Not seen in the last 7 days" report, but I don't know how many systems are out in the wild that are forever broken. This would be an awesome feature if I could count on it.


This is especially frustrating since there are a lot of bugs in the ways they determine asset uniqueness, especially when their own probes make tons of assumptions and can't accurately gather what they deem is useful for uniqueness. Their answer has been LsAgent, which for whatever reason works completely differently than their standard ssh probe on MacOS and does at least come back with a MAC address (noting that's greatly inferior to serial number which should be considered, and is not). I really wish they'd open this product up. All I can say is the door is wide open for those that truly understand asset inventory discovery and are willing to improve their products.

Does LS work? Yes, but only up to a point. It does best with Windows. The rest needs a lot of shaping up. It's like the code base stopped getting any real work 10+ years ago. Sort of sad.

marck1024
#2marck1024 Member Original PosterPosts: 44  
posted: 1/26/2022 2:09:29 PM(UTC)
I was disappointed to find this is still not fixed. I found a computer with a corrupt LsAgent.ini dated 12/19/2021 with agent version 8.4.100.149. That's the latest version of the agent. :(

Active Discussions

Lansweeper Version 10.2.0.0
by  ThomasK   Go to last post Go to first unread
Last post: Today at 6:11:28 AM(UTC)
Lansweeper Certificates
by  Orion Poplawski  
Go to last post Go to first unread
Last post: 7/1/2022 10:11:12 PM(UTC)
Lansweeper Dell warranty lookup not working
by  LANGuy  
Go to last post Go to first unread
Last post: 7/1/2022 1:30:06 PM(UTC)
Lansweeper RedHat 8.5 & SELinux
by  QuelleAcht   Go to last post Go to first unread
Last post: 7/1/2022 1:16:19 PM(UTC)
Lansweeper Suddenly seeing Access Denied scanning errors?
by  Erik.T  
Go to last post Go to first unread
Last post: 7/1/2022 9:38:17 AM(UTC)
Lansweeper Single Line report with H/D
by  Ioannis   Go to last post Go to first unread
Last post: 7/1/2022 7:53:23 AM(UTC)
Lansweeper Lansweeper Dark Theme
by  mrobbins  
Go to last post Go to first unread
Last post: 6/30/2022 5:38:01 PM(UTC)