Notification

Icon
Error

Deploying Microsoft Store Apps "offline"

Posted: Friday, October 25, 2019 9:41:20 AM(UTC)
MakeBug

MakeBug

Member Original PosterPosts: 56
0
Like
Hi guys,

We have disabled the Microsoft Store in our whole domain.
Now I have received a request to install the Translator app from microsoft, which is only available in the store.
I checked the internet if it's possible to download some kind of installer for apps to deploy them to "offline"-clients , or in our case: clients who don't have access to the store. To my surprise it's actually possible (I didn't expect microsoft to think of this, I haven't seen much offline-friendlyness since w10 came out).

It's possible to download the AppxBundle and install it via powershell.

So I downloaded it and if I run the command below manually on a client, it works perfect.
Code:
add-appxpackage \\Server\PackageShare$\lovely.AppxBundle


Next I tried to create a package with either the command (powershell.exe -command "add-appxpackage \\Server\PackageShare$\lovely.AppxBundle") or the ps1. It looked fine at first, the package returned success at the end.
But when I went to check, the app was not installed.
I've tried different variations using commands or external scripts. The deplyoments always end successfully but just doesn't seem do anything on the client.

Did anyone else already try to install store apps this way?
I know there's google translator aso. online but the users asked for this specific app. My hands are bound, if it's possible to deploy it I have to do it (if someone can confirm that it's not possible I'm perfectly happy with that too).
RKCar
#1RKCar Member Posts: 82  
posted: 10/25/2019 3:40:24 PM(UTC)
Can you test out a simple PowerShell based script to verify it is the specific action you are performing and not something to do with Powershell in general? I just verified that this works in my environment:

Code:
powershell.exe -command out-file C:\Windows\Temp\hello.txt
CyberCitizen
#2CyberCitizen Member Posts: 368  
posted: 10/28/2019 12:16:55 AM(UTC)
And can you call it via admin command prompt to see if it works normally and installs.
MakeBug
#3MakeBug Member Original PosterPosts: 56  
posted: 11/7/2019 3:48:57 PM(UTC)
Hmm, now there's something I probably should have tested earlier:
Is it possible, that apps cannot be installed for all users at once (or ist there a special command to do that)?
If I login with a local admin and use the "currently logged in" run mode it seems to work Eh?

Active Discussions

Lansweeper Report creation based on FilePathFull for Installation
by  Pang  
Go to last post Go to first unread
Last post: Today at 2:50:23 PM(UTC)
Lansweeper Software Version Compatibility Report (Solved)
by  RC62N   Go to last post Go to first unread
Last post: Yesterday at 5:04:10 PM(UTC)
Lansweeper Reports Email Question
by  muffintopman  
Go to last post Go to first unread
Last post: Yesterday at 3:23:23 PM(UTC)
Lansweeper Ripple20
by  Hendrik.VE  
Go to last post Go to first unread
Last post: 7/8/2020 8:09:35 AM(UTC)
Lansweeper All USB devices connected
by  earmor   Go to last post Go to first unread
Last post: 7/7/2020 1:35:37 PM(UTC)
Lansweeper Software audit with installation date
by  RC62N  
Go to last post Go to first unread
Last post: 7/3/2020 3:39:41 PM(UTC)