Notification

Icon
Error

PCs not appearing in report when searching for software - Asset shows installed software, but does not appear in report when searching for the software

Posted: Friday, November 1, 2019 9:04:15 PM(UTC)
t_edwards

t_edwards

Member Original PosterPosts: 1
0
Like
We're trying to track down which PCs have a particular piece of software installed on them. The scanned asset, when clicked on and browsing the software menu, will show the software is installed, version number, publisher, etc. When running a software report and searching the publisher or software name field for the software it does not show the workstation.

The report shows the asset with the software installed and a report run being narrowed down by "Toad", the software we're looking for. What is missing in the report that's causing it to only show certain devices?

Here is the report:

Code:

Select Top 1000000 tblAssets.AssetID,
  tblAssets.AssetName,
  tsysAssetTypes.AssetTypename,
  tsysAssetTypes.AssetTypeIcon10 As icon,
  tblAssets.IPAddress,
  tblAssets.Lastseen,
  tblAssets.Lasttried,
  tblAssets.Username,
  tblSoftwareUni.SoftID,
  tblSoftwareUni.softwareName,
  tblSoftwareUni.SoftwarePublisher,
  tblSoftware.Installdate,
  tblSoftware.softwareVersion
From tblAssets
  Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
  Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
  Inner Join tblSoftware On tblAssets.AssetID = tblSoftware.AssetID
  Inner Join tblSoftwareUni On tblSoftwareUni.SoftID = tblSoftware.softID
Where tblAssetCustom.State = 1


JacobH
#1JacobH Member Posts: 175  
posted: 11/3/2019 11:16:49 PM(UTC)
Try running the query without the WHERE clause - perhaps the asset you are looking for is not set to 'active' state.

Active Discussions

Lansweeper HP Warranty scan - broken for some products
by  M Redfern   Go to last post Go to first unread
Last post: Today at 12:30:44 PM(UTC)
Lansweeper Worked time
by  Imrane DESSAI  
Go to last post Go to first unread
Last post: Today at 7:14:40 AM(UTC)
Lansweeper Adding Owner/User information to Assets:All column report
by  ssmarr5   Go to last post Go to first unread
Last post: Today at 12:15:01 AM(UTC)
Lansweeper Send users email about low disk space
by  DontByteMe  
Go to last post Go to first unread
Last post: Yesterday at 10:02:43 PM(UTC)
Lansweeper Can reports be directed to a file server
by  RKCar   Go to last post Go to first unread
Last post: Yesterday at 9:40:18 PM(UTC)
Lansweeper Monitor Model- Generic PnP Monitor
by  Roger D.  
Go to last post Go to first unread
Last post: Yesterday at 7:22:01 PM(UTC)
Lansweeper Are Deleted Dashboard Tabs Retrievable?
by  Rob-CD   Go to last post Go to first unread
Last post: Yesterday at 4:04:45 PM(UTC)
Lansweeper Assets Not Seen in 90 Days not Automatically becoming Inactive
by  Rob-CD  
Go to last post Go to first unread
Last post: Yesterday at 4:00:00 PM(UTC)