Notification

Icon
Error

Launch PowerShell remote PSSession

Posted: Friday, August 9, 2019 12:07:41 PM(UTC)
Ian

Ian

Member Original PosterPosts: 3
1
Like
This issue has been solved! Click here to view the solution
Hi Folks,

I am trying to launch the below command from the basic actions menu for an asset but the PowerShell window displays and then closes with no output

I have the command working from a normal PowerShell window on the Lansweeper server.

The two commands I have tried are below:
powershell.exe Enter-PSSession -ComputerName {computer}
powershell.exe set-executionpolicy bypass Enter-PSSession -ComputerName {computer}

Any ideas what I am doing wrong?
steveb
#1steveb Member Posts: 10  
posted: 9/5/2019 10:21:40 PM(UTC)
Its not exactly what you want but it does work via psexec.

{actionpath}psexec.exe /accepteula \\{smartname} powershell.exe

I cannot get it to work the same way you were trying it either.
steveb
#2steveb Member Posts: 10  
posted: 9/5/2019 10:36:52 PM(UTC)
I got it to work. Try adding the -noexit parameter.

powershell.exe -noexit Enter-PSSession -ComputerName {smartname}

For anyone else, here is the how to I followed for enabling remote powershell sessions if you don't already have it setup.

remote powershell enable
Ian
#3Ian Member Original PosterPosts: 3  
posted: 9/9/2019 12:10:56 PM(UTC)
Originally Posted by: steveb Go to Quoted Post
I got it to work. Try adding the -noexit parameter.

powershell.exe -noexit Enter-PSSession -ComputerName {smartname}

For anyone else, here is the how to I followed for enabling remote powershell sessions if you don't already have it setup.

remote powershell enable


Thanks for that Steve, it worked perfectly.

Active Discussions

Lansweeper Assets disappearing
by  Leeroy_J   Go to last post Go to first unread
Last post: Today at 12:44:56 AM(UTC)
Lansweeper Old Windows 7 Assets
by  cycleheat  
Go to last post Go to first unread
Last post: Yesterday at 9:45:35 PM(UTC)
Lansweeper Admins view all helpdesk tickets
by  thare   Go to last post Go to first unread
Last post: Yesterday at 8:50:29 PM(UTC)
Lansweeper Lansweeper Reporting Old Assets as New
by  Jpatterson  
Go to last post Go to first unread
Last post: Yesterday at 8:09:00 PM(UTC)
Lansweeper Change History or Restore of Custom Reports?
by  GoHawks5   Go to last post Go to first unread
Last post: Yesterday at 4:20:52 PM(UTC)
Lansweeper agents can't create new tabs
by  Esben.D  
Go to last post Go to first unread
Last post: Yesterday at 3:51:07 PM(UTC)
Lansweeper Schedule/Calendar Ticket
by  enush   Go to last post Go to first unread
Last post: Yesterday at 3:46:21 PM(UTC)