Notification

Icon
Error

Lansweeper warnings sent to an email

Posted: Tuesday, June 25, 2019 2:23:29 PM(UTC)
MilicaM

MilicaM

Member Original PosterPosts: 6
0
Like
Hi,

I have an alert displayed on Lansweeper web console: "License Warning | Your license is limited to 5000 assets. You've reached 95%".

Is there a possibility to receive this warning over an email? And when the assets count is below 95% no email warning is received.

Thank you,
Milica
Esben.D
#1Esben.D Member Administration Posts: 1,895  
posted: 7/12/2019 9:55:15 AM(UTC)
You could create a report about it and use it in a report alert:

Code:
Select Top 1000000 Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) As
  [%]
From tblAssets
  Left Join (Select tblAssets.AssetID
      From tblAssets
        Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
        Inner Join tsysAssetTypes On tsysAssetTypes.AssetType =
          tblAssets.Assettype
        Inner Join tblState On tblState.State = tblAssetCustom.State
      Where tblState.Statename != 'monitor') As SQ1 On SQ1.AssetID =
    tblAssets.AssetID
Having Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) >= 95
MilicaM
#2MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:07:02 AM(UTC)
Hi Esben,

Many thanks for your reply!

I already found solution:

Select Top 1000000 Count(tblAssets.AssetID) As [Asset count],
5000 As [Asset limit],
Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As decimal(8,2)) As
[% used]
From tblAssets
Where tblAssets.AssetUnique Not Like 'Mon:%'
Having Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As
decimal(8,2)) >= 95

Where 5000 is asset limit.

Regards,
Milica
Esben.D
#3Esben.D Member Administration Posts: 1,895  
posted: 7/12/2019 10:16:37 AM(UTC)
You will still have to take into account that Monitor assets are not counted towards the license. So you will have to slightly adjust your report.
MilicaM
#4MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:36:44 AM(UTC)
Hey Esben, thanks for noticed it, but I already put the filter with:

Where tblAssets.AssetUnique Not Like 'Mon:%' :)

Milica

Active Discussions

Lansweeper Vmware Vcenter and Hosts not scanning
by  pkamacho   Go to last post Go to first unread
Last post: Today at 8:33:17 PM(UTC)
Lansweeper Helpdesk Ticket "On-Hold"
by  Chris1052  
Go to last post Go to first unread
Last post: Today at 7:44:01 PM(UTC)
Lansweeper SNMPv3 Scanning of Cisco Devices
by  Bruce.B   Go to last post Go to first unread
Last post: Today at 7:40:08 PM(UTC)
Lansweeper Object reference not set to an instance of an object
by  Bruce.B  
Go to last post Go to first unread
Last post: Today at 6:33:18 PM(UTC)
Lansweeper New Exchange server feature scanning
by  Thomas D.   Go to last post Go to first unread
Last post: Today at 5:00:51 PM(UTC)
Lansweeper AD Users and email
by  CyberCitizen  
Go to last post Go to first unread
Last post: Today at 12:40:54 AM(UTC)
Lansweeper Distrubution Center workstation Map
by  CGIMana79   Go to last post Go to first unread
Last post: Yesterday at 6:00:44 PM(UTC)
Lansweeper Starting ticket # for helpdesk
by  AEM IT  
Go to last post Go to first unread
Last post: Yesterday at 5:17:22 PM(UTC)