Notification

Icon
Error

Add Document as File Link

Posted: Tuesday, June 18, 2019 10:11:32 AM(UTC)
mowo

mowo

Member Original PosterPosts: 3
0
Like
This issue has been solved! Click here to view the solution
Is it possible to add a document to an asset as a file link?

Instead of uploading the document to the IIS server we would like to just have a file link to our file server. Doing so we could keep the directory structure and retain access to the files for other usage.
Esben.D
#1Esben.D Member Administration Posts: 1,982  
posted: 6/19/2019 9:49:14 AM(UTC)
You can use a hyperlink custom field. In configuration\asset pages, you can configure the custom fields name and type. Then you can edit the assets and add the link to the document.
mowo
#2mowo Member Original PosterPosts: 3  
posted: 6/19/2019 10:28:33 AM(UTC)
This is working but the downside is that the link is very long and percent-encoded which makes it difficult to read. Would be great if documents could also be added as file links or if we could specify a display name for the custom field hyperlink.
AZHockeyNut
#3AZHockeyNut Member Alpha Tester Posts: 235  
posted: 6/19/2019 3:18:49 PM(UTC)
mowo, it could be done as in a UNC path (\\server\share) however, the problem is the context under which the application tries to open the file. you might then get into delegation issues etc. Also, as the app transitions to the cloud eventually like everything else seems to, opening those would be much more challenging.
I feel your pain as I wanted to do something similar.
mowo
#4mowo Member Original PosterPosts: 3  
posted: 6/26/2019 2:00:25 PM(UTC)
Using custom hyperlink fields with a file link and a UNC path (e.g. "file://server\dir A\dir B\file.pdf") can be used as a workaround for assets. However, this is not working for e.g. software licenses. Those entries support the upload of documents but don't have custom fields. Would really appreciate if file links would be supported somehow.

Active Discussions

Lansweeper "add cc user" doesn't show the correct listings
by  JLPingree   Go to last post Go to first unread
Last post: Yesterday at 8:12:44 PM(UTC)
Lansweeper Default User Date Format
by  RickW99456  
Go to last post Go to first unread
Last post: Yesterday at 5:00:51 PM(UTC)
Lansweeper Duplicate assets (Servers)
by  FrankSc   Go to last post Go to first unread
Last post: Yesterday at 3:20:28 PM(UTC)
Lansweeper Lansweeper load the disk subsystem
by  Alexey Gorbachev  
Go to last post Go to first unread
Last post: Yesterday at 3:13:17 PM(UTC)
Lansweeper Lost Configuration tab (Admin rights)
by  kspap   Go to last post Go to first unread
Last post: Yesterday at 10:30:12 AM(UTC)
Lansweeper Deployment with different user rights
by  Jupiter_IT  
Go to last post Go to first unread
Last post: Yesterday at 9:39:20 AM(UTC)
Lansweeper cisco fuji device not linking with connected devices
by  char   Go to last post Go to first unread
Last post: 7/5/2020 9:12:07 AM(UTC)
Lansweeper Microsoft CVE-2020-1425
by  Richard_B  
Go to last post Go to first unread
Last post: 7/3/2020 4:29:41 PM(UTC)