Notification

Icon
Error

Windows 10 OS Builds - A report that displays the full Window 10 OS build number

Posted: Thursday, May 16, 2019 8:02:34 PM(UTC)
pfenton

pfenton

Member Original PosterPosts: 27
0
Like
I have pieced together this report that reports the full OS Build of Windows 10. It works, but it relies on 2 custom registry scans. The 2 custom scans are both from \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion. One is ReleaseID, and the other is UBR. In my case they would represent 17763, and 503 respectively.
After looking around at other reports, it seems that both of these keys are being scanned with out the custom scanning. I would like the report to work without the custom scanning, but can't figure it out. I am not a coder. I literally pieced together my report from other reports and a lot of guess work. Any help would be appreciated.


Select Top 1000000 tblAssets.AssetName,
tsysOS.OSname,
tsysOS.Image As icon,
tblAssets.OScode As [OS Build],
SubQuery.Value As [Sub Build],
tblAssets.IPAddress,
tblAssets.Lastseen,
tblRegistry.Value As [Build #]
From tblAssets
Inner Join tsysOS On tsysOS.OScode = tblAssets.OScode
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join (Select tblRegistry.AssetID,
tblRegistry.Regkey,
tblRegistry.Valuename,
tblRegistry.Value,
tblRegistry.Lastchanged
From tblRegistry
Where tblRegistry.Valuename = 'UBR') SubQuery On SubQuery.AssetID =
tblAssets.AssetID
Inner Join tblRegistry On tblAssets.AssetID = tblRegistry.AssetID
Where tblRegistry.Valuename = 'ReleaseID' And tblAssetCustom.State = 1
Order By [OS Build],
[Sub Build]
endyk
#1endyk Member Posts: 24  
posted: 5/17/2019 1:19:57 AM(UTC)
Hello-

I'm not sure I fully understood your needs. But this query below should returns all OS build of windows. You can look at the result set and let me know what you want or don't want included in the result. We can continue from there.

Select Top 1000000
tblAssets.AssetName,
tsysOS.OSname,
tsysOS.Image As icon,
tblAssets.OScode As [OS Build],
tblRegistry.Value As [Sub Build],
tblAssets.IPAddress,
tblAssets.Lastseen,
tblRegistry.Value As [Build #],
tblRegistry.Valuename,
tblAssetCustom.State
From tblAssets
Inner Join tsysOS
On tsysOS.OScode = tblAssets.OScode
Inner Join tblAssetCustom
On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tblRegistry
On tblAssets.AssetID = tblRegistry.AssetID
Order By [OS Build],
[Sub Build]

Active Discussions

Lansweeper Hyper-V guests dissapeared and reappeared
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:30:47 PM(UTC)
Lansweeper DB cleanup script
by  William382  
Go to last post Go to first unread
Last post: Yesterday at 4:23:43 PM(UTC)
Lansweeper Installing MS KB with Deploy
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:01:45 PM(UTC)
Lansweeper Ticket Info Meter incorrect
by  pfalls  
Go to last post Go to first unread
Last post: Yesterday at 3:27:44 PM(UTC)
Lansweeper Asset Checkboxes in reports
by  ufficioced   Go to last post Go to first unread
Last post: Yesterday at 1:22:17 PM(UTC)
Lansweeper Silent "Run as logged in user" option
by  CyberCitizen  
Go to last post Go to first unread
Last post: Yesterday at 3:45:25 AM(UTC)
Lansweeper New ticket creation not emailing the user
by  MVMIC IT LANSWEEPER   Go to last post Go to first unread
Last post: 11/15/2019 5:36:23 PM(UTC)