Notification

Icon
Error

Jelly
#0Jelly Member Posts: 7  
posted: 5/17/2019 12:09:20 AM(UTC)
Originally Posted by: smozie Go to Quoted Post
I am trying to write a report to find assets within our US domain, that are tied to the tblADUsers.Department %IT% and do no have versions 6.0.0 or 6.0.1 of Traps on their system. I run the code below and what I get back is a bit of a mess, looking for help.

Code:

Select Top 100000 tblAssets.AssetID,
  tblAssets.Domain,
  tblAssets.Username,
  tblADusers.Firstname,
  tblADusers.Lastname,
   tblADusers.Department
From tblAssets
  Inner Join tsysIPLocations On tsysIPLocations.LocationID =
    tblAssets.LocationID
  Left Join tblADusers On tblADusers.Username = tblAssets.Username And
    tblADusers.Userdomain = tblAssets.Userdomain
  Inner Join tblSoftware On tblAssets.AssetID = tblSoftware.AssetID
  Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID
Where tblSoftwareUni.softwareName Like '%traps%' And tblSoftware.softwareVersion Not
  Like '6.0.0%' And tblSoftware.softwareVersion Not Like '6.0.1%' AND tblADusers.Userdomain Like '%US%' And tblADusers.Department Like '%IT%'
Order By tblAssets.AssetName





Try this changed your left join and a few other things. Personally I wouldn't post with the software names/versions/domain/department info not anonymized.
Code:

Select Top 100000 tblAssets.AssetID,
  tblAssets.Domain,
  tblAssets.Username,
  tblADusers.Firstname,
  tblADusers.Lastname,
   tblADusers.Department
From tblAssets
  Inner Join tsysIPLocations On tsysIPLocations.LocationID = tblAssets.LocationID
  Left Join tblADusers On tblAssets.Username = tblADusers.Username 
  Inner Join tblSoftware On tblAssets.AssetID = tblSoftware.AssetID
  Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID
Where tblSoftwareUni.softwareName Like '%traps%' 
And tblSoftware.softwareVersion Not Like '6.0.0%' 
And tblSoftware.softwareVersion Not Like '6.0.1%' 
AND tblAssets.Domain = 'us'
And tblADusers.Department Like '%IT%'
Order By tblAssets.AssetName



Active Discussions

Lansweeper Report for Microsoft Win 7 Extended Support
by  RC62N   Go to last post Go to first unread
Last post: Yesterday at 6:46:53 PM(UTC)
Lansweeper How to make a colour coded report
by  B.Rutherford  
Go to last post Go to first unread
Last post: Yesterday at 4:27:06 PM(UTC)
Report Center All switches and the assets connected to them
by  NWSF   Go to last post Go to first unread
Last post: 12/12/2019 5:23:34 PM(UTC)
Lansweeper Report showing single asset type
by  RC62N  
Go to last post Go to first unread
Last post: 12/11/2019 10:02:41 PM(UTC)
Report Center .Net 4.5 through 4.8 report - Reg Key scanning based
by  Martin Schulz   Go to last post Go to first unread
Last post: 12/11/2019 11:55:24 AM(UTC)
Lansweeper Assets and Owner listing help
by  ssmarr5  
Go to last post Go to first unread
Last post: 12/10/2019 9:23:09 PM(UTC)
Lansweeper HPE SAS Solid State Drives failure report
by  Tommy75   Go to last post Go to first unread
Last post: 12/10/2019 8:04:05 AM(UTC)
Lansweeper Adding Owner/User information to Assets:All column report
by  ssmarr5  
Go to last post Go to first unread
Last post: 12/10/2019 12:15:01 AM(UTC)