Notification

Icon
Error

"Exception" or "Exclusion" in Default Report - Trying to customize a default report

Posted: Thursday, February 7, 2019 8:04:10 PM(UTC)
Cripple.Zero

Cripple.Zero

Member Original PosterPosts: 17
0
Like
This issue has been solved! Click here to view the solution
I am trying to add an exclusion to one of the default reports in LANSweeper. It is the "Error: WMI Access Denied" report.

On our network we have PCL-like devices that are used on our manufacturing floor. They are boxes that have an Ethernet port and have a highly customized Windows embedded environment, but aren't robust enough to install software like Office, anti-virus, etc. They only provide a Windows GUI for engineers to access parts of the machinery that these PCL boxes control.

That being said, I would like to exclude those boxes from the Access Denied listing. There are quite a few of them across our different plants, so having them show up on the report skews our numbers by quite a lot. Each PCL device has a scanned asset name of "GVxxxx" (where 'xxxxx' represents the version number and a random ID unique to each box).

I am trying to exclude from the report all but the beginning "GV" AssetName portion. I have tried many different combinations of LIKE and NOT LIKE with operators and wildcards with <>, % or _


=============================
Select Top 1000000 tblErrors.AssetID,
tsysAssetTypes.AssetTypeIcon10 As icon,
tblAssets.AssetName,
'WMI Access denied. Username(s) tried: ' + tblErrors.ErrorText As Message,
tblAssets.Domain,
tsysAssetTypes.AssetTypename As Type,
tblAssets.IPAddress As [IP Address],
tblAssets.Description,
tblAssetCustom.Manufacturer,
tblAssetCustom.Model,
tblAssetCustom.Location,
tsysIPLocations.IPLocation,
tblErrors.Lastchanged As [Last changed],
tblAssets.Firstseen,
tblAssets.Lastseen,
'red' As foregroundcolor
From tblErrors
Inner Join tblAssets On tblErrors.AssetID = tblAssets.AssetID
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tsysasseterrortypes On
tblErrors.ErrorType = tsysasseterrortypes.Errortype
Left Outer Join tblOperatingsystem On
tblAssets.AssetID = tblOperatingsystem.AssetID
Left Outer Join tsysIPLocations On tblAssets.LocationID =
tsysIPLocations.LocationID
Inner Join tsysAssetTypes On tblAssets.Assettype = tsysAssetTypes.AssetType
Where tblAssets.AssetName <> 'GV%' And tblAssetCustom.State = 1 And
tblOperatingsystem.AssetID Is Null And tblErrors.ErrorType = 1
Order By [Last changed] Desc,
tblAssets.AssetName

===================================

I'm not sure which combination is needed to exclude "GV" devices from the report. Am I placing the exclusion in the wrong part of the code?
JacobH
#1JacobH Member Posts: 165  
posted: 2/8/2019 9:26:26 PM(UTC)
Where tblAssets.AssetName not like 'GV%'

worked for me

Cripple.Zero
#2Cripple.Zero Member Original PosterPosts: 17  
posted: 2/8/2019 9:38:30 PM(UTC)
Thank you. I swear I did that, but then again, it was around 11pm and my eyes were getting squinty!!!

That did work, btw. This helps tremendously!

Active Discussions

Lansweeper how to add windows and office licenses manually.
by  cesar.ti   Go to last post Go to first unread
Last post: Yesterday at 7:32:10 PM(UTC)
Lansweeper User roles and permissions
Belarus  RKCar  
Go to last post Go to first unread
Last post: Yesterday at 6:23:38 PM(UTC)
Lansweeper Deployment condition
by  RKCar   Go to last post Go to first unread
Last post: Yesterday at 4:07:30 PM(UTC)
Lansweeper HP Printer not showing correctly
by  JacobH  
Go to last post Go to first unread
Last post: Yesterday at 1:32:54 PM(UTC)
Lansweeper Moving Assets in Location not Saving
by  brodiemac   Go to last post Go to first unread
Last post: Yesterday at 12:23:04 PM(UTC)
Lansweeper Scanning includes IOS devices even though I exclude them??
by  steveb  
Go to last post Go to first unread
Last post: 8/22/2019 11:05:33 PM(UTC)
Lansweeper lsagent not scanning/sending when using relay
by  Esben.D   Go to last post Go to first unread
Last post: 8/19/2019 12:31:02 PM(UTC)
Lansweeper Check if Netbios is disabled over TCP/IP
by  TaherMD  
Go to last post Go to first unread
Last post: 8/19/2019 6:00:51 AM(UTC)