Notification

Icon
Error

WMI Security (Powershell/Lansweeper)

Posted: Friday, June 4, 2010 12:49:37 AM(UTC)
Cobra7

Cobra7

Member Posts: 148
0
Like
Not directly related to Lansweeper but it is affecting Lansweeper.

I'm trying to use Powershell to access the Win32_printer on various PC's.

When I do my own I can see all printers:
Code:
Get-WMIObject -class Win32_printers


When I do my own via network, I can also see my own:
Code:
Get-WMIObject -class win32_printers -computername (PC name)


When I do someone elses PC, I can only see local printers, not the network (mapped) printers
Code:
Get-WMIObject -class Win32_printers -computername (PC name)


When I do someone elses PC with the current user credentials, I can see everything:
Code:
$cred = get-credentials;get-wmiobject -credentials $cred -class Win32_printers -computername (PC name)


When I do the above as domain administrator, I can only see local printers.

Also when I check the printers on a PC under Lansweeper, I also only see local printers.

I know I am set up as a local admin on these PC's just like domain administrator, so anyone know whats going on?
Lansweeper
#1Lansweeper Member Administration  
posted: 6/4/2010 9:39:03 AM(UTC)
From what I understand Win32_printer shows the printers for the current user and the printers installed for everyone.
The current user is in this case the user performing the lansweeper scan.
Cobra7
#2Cobra7 Member  
posted: 6/4/2010 5:06:11 PM(UTC)
*ponders* So my guess is when I run the query with my credentials, it looks for default printers and printers under my profile (which there are none).

That must also be why Lansweeper (useing domain administrator credentials) doesn't see the users printers either.

Thanks for the info.

Active Discussions

Lansweeper Windows 10 Build Version report
by  pfenton   Go to last post Go to first unread
Last post: Yesterday at 4:23:31 AM(UTC)
Lansweeper Scan an IP range from a different subnet
by  pfenton  
Go to last post Go to first unread
Last post: Yesterday at 4:03:06 AM(UTC)
Lansweeper Adobe reader install
by  Cardealer_Roc   Go to last post Go to first unread
Last post: 11/17/2017 11:19:28 PM(UTC)
Lansweeper Add MIB for snmp devices
by  crashff  
Go to last post Go to first unread
Last post: 11/17/2017 10:56:03 PM(UTC)
Lansweeper Wrong uptimes for windows 10 assets
by  cbenedict   Go to last post Go to first unread
Last post: 11/17/2017 9:13:48 PM(UTC)
Lansweeper Hide a ticket for just me
by  jeremy.parker  
Go to last post Go to first unread
Last post: 11/17/2017 8:21:41 PM(UTC)
Lansweeper Cleanup options don't work
by  czubai   Go to last post Go to first unread
Last post: 11/17/2017 6:08:49 PM(UTC)
Lansweeper Lansweeper Raports problem
by  RpiTMS  
Go to last post Go to first unread
Last post: 11/17/2017 3:24:54 PM(UTC)