Notification

Icon
Error

WMI Security (Powershell/Lansweeper)

Posted: Friday, June 4, 2010 12:49:37 AM(UTC)
Cobra7

Cobra7

Member Premium Users Posts: 146
0
Like
Not directly related to Lansweeper but it is affecting Lansweeper.

I'm trying to use Powershell to access the Win32_printer on various PC's.

When I do my own I can see all printers:
Code:
Get-WMIObject -class Win32_printers


When I do my own via network, I can also see my own:
Code:
Get-WMIObject -class win32_printers -computername (PC name)


When I do someone elses PC, I can only see local printers, not the network (mapped) printers
Code:
Get-WMIObject -class Win32_printers -computername (PC name)


When I do someone elses PC with the current user credentials, I can see everything:
Code:
$cred = get-credentials;get-wmiobject -credentials $cred -class Win32_printers -computername (PC name)


When I do the above as domain administrator, I can only see local printers.

Also when I check the printers on a PC under Lansweeper, I also only see local printers.

I know I am set up as a local admin on these PC's just like domain administrator, so anyone know whats going on?
Lansweeper
#-29Lansweeper Member Administration  
posted: 6/4/2010 9:39:03 AM(UTC)
From what I understand Win32_printer shows the printers for the current user and the printers installed for everyone.
The current user is in this case the user performing the lansweeper scan.
Cobra7
#-28Cobra7 Member Premium Users  
posted: 6/4/2010 5:06:11 PM(UTC)
*ponders* So my guess is when I run the query with my credentials, it looks for default printers and printers under my profile (which there are none).

That must also be why Lansweeper (useing domain administrator credentials) doesn't see the users printers either.

Thanks for the info.

Top Rated

1 Lansweeper Lansweeper 5.2 (recent update)
by  MikeInLa  
Go to last post Go to first unread
Last post: 11/26/2014 9:57:29 AM(UTC)
2 Lansweeper Post here about your lansweeper setup.
by  Lansweeper  
Go to last post Go to first unread
Last post: 1/28/2015 8:38:33 PM(UTC)
3 Lansweeper Approve software only for certain PCs or Users
by  sarmo  
Go to last post Go to first unread
Last post: 11/13/2014 4:09:33 PM(UTC)
5 Lansweeper Deployment monitor
by  DaveinJP  
Go to last post Go to first unread
Last post: 1/17/2015 12:27:22 PM(UTC)
6 Lansweeper Deploy package - pre-defined "run mode" by package
by  servicedesk  
Go to last post Go to first unread
Last post: 1/7/2015 1:58:53 PM(UTC)
7 Lansweeper Add ability to adjust asset state visibility
by  WING987  
Go to last post Go to first unread
Last post: 1/9/2015 10:51:34 AM(UTC)
8 Lansweeper Exclude Specific Asset Groups from Reports
by  WhatTheFrenchToast  
Go to last post Go to first unread
Last post: 1/9/2015 11:00:24 PM(UTC)

Active Discussions

Lansweeper IE8 deployment fails
by  Susan.A   Go to last post Go to first unread
Last post: Today at 10:13:12 AM(UTC)
Lansweeper History of manual changes
by  Susan.A  
Go to last post Go to first unread
Last post: Today at 10:01:41 AM(UTC)
Lansweeper Change computer name action
by  Susan.A   Go to last post Go to first unread
Last post: Today at 9:59:34 AM(UTC)
Lansweeper website Login gives prompt everytime
by  Susan.A  
Go to last post Go to first unread
Last post: Today at 9:55:06 AM(UTC)
Lansweeper Report listing newly added devices
by  Susan.A   Go to last post Go to first unread
Last post: Today at 9:47:19 AM(UTC)
Lansweeper OUs for Apple Computers?
by  Susan.A  
Go to last post Go to first unread
Last post: Today at 9:26:25 AM(UTC)
Lansweeper Query for OS and Office
by  SimplyClueless   Go to last post Go to first unread
Last post: Yesterday at 7:57:26 PM(UTC)