Lansweeper Installation Requirements 2022 Update

Lansweeper will be updating its installation requirements this year to stay in line with modern technologies and provide the best and most secure user experience for Lansweeper installations.

As new technologies become the standard, and outdated operating systems are going end of life, it only makes sense to follow the market to ensure a safe and modern Lansweeper setup. This year, Lansweeper is making two big changes which you should review to ensure that you'll be able to upgrade Lansweeper without issues, and if needed, plan your migration.

SQL Server Versions Support Ending

SQL Server 2012 is scheduled to go end of life on July 12, 2022. As a result, we will also be ending Lansweeper support for SQL Server version 2012 and lower (2008 and 2008R2) sometime after this official EOL date. This will include all editions of these SQL Server versions (Standard, Web, Enterprise, Developer, and Express). If you are running Lansweeper using SQL Server 2012 or lower, you will need to plan your migration to SQL Server 2014 or higher.

Multiple Operating System Versions Support Ending

Lansweeper is moving to the 64-bit era. Additionally, we're bringing the supported operating systems more in line with Microsoft end of life status. This means that later this year, we will be ending support for installing Lansweper on a whole list of older operating systems. Specifically:

  • All 32-bit operating systems
  • Windows 7 SP1
  • Windows Server 2008 R2
  • Windows 10, version 2004
  • Windows 10, version 1909
  • Windows 10, version 1903
  • Windows 10, version 1803
  • Windows 10, version 1709
  • Windows 10, version 1703
  • Windows 10, version 1511

Plan Your Migration

In summary, we will only be changing the Lansweeper installation requirements as documented in the Lansweeper installation requirements. This means that all servers that will host a Lansweeper component (database, webserver and/or scanning server) will need to meet these updated requirements. This does not mean that we will no longer be scanning assets that are using these outdated OS versions. The scanning requirements will remain unchanged.

While we don't have exact dates yet on when these changes will take place, it is best you plan your migration now if you have Lansweeper running on one of the components mentioned above. You can easily migrate Lansweeper to a new server by following the instructions on our migration knowledgebase article.

Share on facebook
Share on twitter
Share on linkedin
Share on reddit
Share on email

You may also like...

Try Lansweeper for Free

Learn why Lansweeper is used by thousands of enterprises worldwide.​