Internet Explorer 11 Deprecation

Starting from Lansweeper version 9.1, Internet Explorer 11 will no longer be supported. A modern browser will be required to use Lansweeper.

With Internet Explorer 11 heading toward its end of life, Lansweeper is getting a head start and is no longer supporting IE 11 in Lansweeper version 9.1 and higher. People that still attempt to use Lansweeper with Internet Explorer 11 will find that access has been blocked and that they will have to switch to a newer browser. For some of the older operating systems that do not yet automatically have the newer Chromium-based Edge browser, you will need to install a modern browser first before you can start working with Lansweeper locally.

Lansweeper version 9.1 is now available on the update page. You can find a list of all the changes in our changelog.

Share on facebook
Share on twitter
Share on linkedin
Share on reddit
Share on email

You may also like...

Try Lansweeper for Free

Learn why Lansweeper is used by thousands of enterprises worldwide.​