“Could not load type System.ServiceModel.Activation. HttpModule”

If ASP.NET is not properly enabled (anymore) on the server hosting your Lansweeper web console, your console may become inaccessible and you may encounter the error below. This article explains how to resolve this issue. The exact instructions you should follow depend on which operating system you are using.

Could not load type 'System.ServiceModel.Activation.HttpModule' from assembly 'System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

Windows 8 and more recent operating systems

To resolve this issue if you are running Windows 8 or a more recent operating system, follow the steps below. Alternatively, you can access Turn Windows Features On/Off on the computer and register ASP.NET there. On Server operating systems, you can use Server Manager for ASP.NET registration.

  1. On the machine hosting your Lansweeper web console, run Command Prompt as an administrator.
    running Command Prompt as an administrator
  2. Type the following command and hit Enter to enable ASP.NET:
    dism /online /enable-feature /featurename:IIS-ASPNET45 /all
    registering ASP.NET on Windows 8 or higher
  3. Reboot the machine hosting your Lansweeper web console.

Operating systems below Windows 8

To resolve this issue if you are running an operating system version below Windows 8, do the following:

  1. On the machine hosting your Lansweeper web console, run Command Prompt as an administrator.
    running Command Prompt as an administrator
  2. Type the following command and hit Enter to navigate to the appropriate folder:
    cd\Windows\Microsoft.NET\Framework64\v4.0.30319
    navigating Command Prompt
  3. Type the following command and hit Enter to enable ASP.NET:
    aspnet_regiis.exe -I
    registering ASP.NET
  4. Reboot the machine hosting your Lansweeper web console.

Related Articles