Notification

Icon
Error

Windows: Not seen in the last 30 days (Built-in)

Posted: Thursday, November 20, 2014 11:43:08 AM(UTC)
Daniel.B

Daniel.B

Member Original PosterPosts: 1,150
0
Like
Old name: Computer: Not seen in the last 30 days (Built-in)

The report below lists Windows based assets that were not scanned within the last 30 days

The report will only list assets that meet all of the following criteria:
  • The asset state is set to "active".
  • The asset has been successfully scanned at least once.
  • The asset is a Windows computer.
  • The Last seen date is more than 30 days ago.

Code:

Select Top 1000000 tblAssets.AssetID,
  tblAssets.AssetName,
  tblAssets.Domain,
  tblAssets.Username,
  tblAssets.Userdomain,
  Coalesce(tsysOS.Image, tsysAssetTypes.AssetTypeIcon10) As icon,
  tblAssets.IPAddress,
  tsysIPLocations.IPLocation,
  tblAssetCustom.Manufacturer,
  tblAssetCustom.Model,
  tsysOS.OSname As OS,
  tblAssets.SP,
  tblAssets.Lastseen,
  tblAssets.Lasttried,
  tsysAssetTypes.AssetTypename
From tblAssets
  Left Join tsysOS On tsysOS.OScode = tblAssets.OScode
  Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
  Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
  Inner Join tsysIPLocations On tsysIPLocations.LocationID =
    tblAssets.LocationID
  Inner Join tblState On tblState.State = tblAssetCustom.State
Where tblAssets.Lastseen < GetDate() - 30 And tblState.Statename = 'Active' And
  (tsysAssetTypes.AssetTypename = 'Windows' Or tsysAssetTypes.AssetTypename =
    'Windows CE')
Order By tblAssets.Domain,
  tblAssets.AssetName
Shawn
#1Shawn Member Posts: 4  
posted: 6/24/2020 6:50:46 PM(UTC)
I personally do not want to see assets in the last 30 days, I want to see them older than 30 days. I used the statement below this instead of "Where tblAssets.Lastseen < GetDate() - 30"

Where tblAssets.Lastseen Between DateAdd(day, -999, Current_TimeStamp)
And DateAdd(day, -30, Current_TimeStamp)

Active Discussions

Lansweeper try to scan for software license and not working?
by  rader   Go to last post Go to first unread
Last post: Today at 4:25:37 PM(UTC)
Lansweeper LsAgent uninstalled itself (Windows 10 Enterprise)
by  LsUsers70  
Go to last post Go to first unread
Last post: Today at 3:05:37 PM(UTC)
Lansweeper Deploying PowerShell script
by  FreddieIT   Go to last post Go to first unread
Last post: Today at 10:57:34 AM(UTC)
Lansweeper Deploy package - add registry key to HKCU
by  Bginchereau  
Go to last post Go to first unread
Last post: Yesterday at 5:26:16 PM(UTC)
Lansweeper Duplicate Items
by  Tim Van Engeland   Go to last post Go to first unread
Last post: Yesterday at 2:46:32 PM(UTC)
Lansweeper Latest LsAgent version for Windows?
by  mg83  
Go to last post Go to first unread
Last post: Yesterday at 11:07:51 AM(UTC)
Lansweeper Exchange scanning
by  brama   Go to last post Go to first unread
Last post: Yesterday at 8:56:01 AM(UTC)