Notification

Icon
Error

SCCM scanning incorrectly reporting last seen results - SCCM scanning showing incorrect tblAssets.Lastseen results

Posted: Friday, May 20, 2022 12:34:52 AM(UTC)
SWResearch

SWResearch

Member Original PosterPosts: 4
1
Like
Noticed that a number of our assets were remaining active and also asset reports using tblAssets.Lastseen were showing todays date, even when an asset had been decommissioned or offline for several weeks. The timestamp matches the last SCCM scan time. Had assumed Lansweeper would have based it on SCCM client activity (software or hardware scan dates). I've now disabled SCCM scanning and changed the reports to use either tbleAssets.LastLsAgent or tblAssets.LastActiveScan (see below) until tblAssets.Lastseen starts displaying the last active scan info.
Quote:
Case
When IsDate(tblAssets.LastLsAgent) = 1 And IsDate(tblAssets.LastActiveScan)
= 0 Then tblAssets.LastLsAgent
When IsDate(tblAssets.LastActiveScan) = 1 And IsDate(tblAssets.LastLsAgent)
= 0 Then tblAssets.LastActiveScan
When tblAssets.LastLsAgent > tblAssets.LastActiveScan Then
tblAssets.LastLsAgent
When tblAssets.LastActiveScan > tblAssets.LastLsAgent Then
tblAssets.LastActiveScan
Else ''
End As [Last Scan Date]
vqT4cDoP9iXyMZwoDUWU
#1vqT4cDoP9iXyMZwoDUWU Member Posts: 33  
posted: 5/31/2022 7:01:52 PM(UTC)
I discovered a similar issue (Last Seen updates based off of SCCM) with SCCM integration in Lansweeper v8.x. If I recall correctly, this was tracked by Lansweeper as LAN-4040 and was targeted for resolution a year ago, but I haven't seen it pop up in any release notes.

So we stopped using SCCM scanning in Lansweeper almost immediately after starting, which was a shame because I spent about 18 months troubleshooting with Lansweeper to get SCCM integration going in v7.x & 8.x.

Active Discussions

Lansweeper Version 10.2.0.0
by  ThomasK   Go to last post Go to first unread
Last post: Today at 6:11:28 AM(UTC)
Lansweeper Certificates
by  Orion Poplawski  
Go to last post Go to first unread
Last post: 7/1/2022 10:11:12 PM(UTC)
Lansweeper Dell warranty lookup not working
by  LANGuy  
Go to last post Go to first unread
Last post: 7/1/2022 1:30:06 PM(UTC)
Lansweeper RedHat 8.5 & SELinux
by  QuelleAcht   Go to last post Go to first unread
Last post: 7/1/2022 1:16:19 PM(UTC)
Lansweeper Suddenly seeing Access Denied scanning errors?
by  Erik.T  
Go to last post Go to first unread
Last post: 7/1/2022 9:38:17 AM(UTC)
Lansweeper Single Line report with H/D
by  Ioannis   Go to last post Go to first unread
Last post: 7/1/2022 7:53:23 AM(UTC)
Lansweeper Lansweeper Dark Theme
by  mrobbins  
Go to last post Go to first unread
Last post: 6/30/2022 5:38:01 PM(UTC)