Notification

Icon
Error

Configuring SSL in IIS Express issue

Posted: Thursday, November 25, 2021 10:45:02 AM(UTC)
saffo

saffo

Member Original PosterPosts: 6
1
Like
Hello,

So i did the following:
https://www.lansweeper.c...gure-ssl-in-iis-express/

But i get the following error if i try access it:

"NET::ERR_CERT_COMMON_NAME_INVALID"

I made sure it is the same certificate that i adjusted with the guide.

Anyone exprienced this?

Luke Maslany
#1Luke Maslany Member Posts: 3  
posted: 12/4/2021 4:54:03 PM(UTC)
Just to rule out the basics: is the common name on the certificate the same fully qualified domain name you used in the URL in the web browser?

(remember that if the certificate has a fully qualified domain name, and you try to access it in the browser by IP address or just using the hostname, there will be a mismatch between the names which can result in the error you mention)
saffo
#2saffo Member Original PosterPosts: 6  
posted: 12/6/2021 9:57:31 AM(UTC)
Originally Posted by: Luke Maslany Go to Quoted Post
Just to rule out the basics: is the common name on the certificate the same fully qualified domain name you used in the URL in the web browser?

(remember that if the certificate has a fully qualified domain name, and you try to access it in the browser by IP address or just using the hostname, there will be a mismatch between the names which can result in the error you mention)


Yes it has but i think the problem is with the SAN in the certificate. It is "DNS-name=localhost". If i type that on the computer where Lansweeper itself is installed then it works as intended but if i try that on another computer then it makes sense that i wont work since it redirects it to itself "localhost". If i try to put the FQDN, IP or pc name of the computer where lansweeper is installed then there is a mismatch since it is looking for "localhost".

saffo attached the following image(s):
Knipsel.JPG

Active Discussions

Lansweeper SSL with IIS Express Not working
by  fjca   Go to last post Go to first unread
Last post: Yesterday at 8:16:46 PM(UTC)
Lansweeper LsAgent Reliability Problems
by  marck1024  
Go to last post Go to first unread
Last post: Yesterday at 2:09:29 PM(UTC)
Lansweeper 32-BIT Linux LsAgent-linux
by  Anup Chhetri   Go to last post Go to first unread
Last post: Yesterday at 1:30:15 PM(UTC)
Lansweeper Default Scanned item intervals
by  SteelOG  
Go to last post Go to first unread
Last post: 1/25/2022 8:22:45 PM(UTC)
Lansweeper How to delete an asset
by  tgas   Go to last post Go to first unread
Last post: 1/25/2022 4:00:10 PM(UTC)
Lansweeper Can you track local printers attached to Desktops?
by  hirogen  
Go to last post Go to first unread
Last post: 1/25/2022 2:48:22 PM(UTC)
Lansweeper Duplicates - different IP address
by  Lenven   Go to last post Go to first unread
Last post: 1/25/2022 2:12:40 PM(UTC)
Lansweeper Antivirus Up to Date or Not?
by  Lindner  
Go to last post Go to first unread
Last post: 1/25/2022 12:46:21 PM(UTC)