Notification

Icon
Error

Adding "multi-part" Conditions to Reports - Conditions needed exceed data columns in Report Builder

Posted: Thursday, May 13, 2021 1:25:34 PM(UTC)
Cripple.Zero

Cripple.Zero

Member Original PosterPosts: 46
0
Like
I'm building a few reports based on stored inventory vs. deployed inventory.

Without getting into the details of the individual reports, I am making simple reports based on 5 separate types of assets (10 reports total = deployed & stored per asset): Monitors, Laptops, Desktops, Surfaces & Docking Stations.

By default LS provides 3 columns for conditional reporting (i.e. like, not like, = ... etc.). Once I add a fourth condition, I receive "The multi-part identifier "<TABLE NAME>" could not be bound."

Is there a way to add or combine conditions that will conform to the 3 condition default, or will I need to get really creative on how the report pulls its data?

It started out really simple.....lol
Brandon
#1Brandon Member Posts: 154  
posted: 5/13/2021 1:43:35 PM(UTC)
Can you please post your report here? That will make it a lot easier to give advice.
Cripple.Zero
#2Cripple.Zero Member Original PosterPosts: 46  
posted: 5/13/2021 1:50:36 PM(UTC)
Dang...

Spoke too soon.

I figured out the problem. It was really simple - I was placing my conditions in the "OR" statements and appeared correct until I changed a parameter.

All I had to do was replace the "OR" statements with "AND" statements.

d'oh! d'oh! d'oh!


Brandon
#3Brandon Member Posts: 154  
posted: 5/13/2021 1:52:17 PM(UTC)
Good job! Glad you figured it out.

Active Discussions

Lansweeper Enterprise Options in Menu Bar/Configuration
by  mk@allan   Go to last post Go to first unread
Last post: 6/18/2021 7:38:43 PM(UTC)
Lansweeper No One getting back to me from Lansweeper
by  Kenneth Lindsay  
Go to last post Go to first unread
Last post: 6/18/2021 3:31:06 PM(UTC)
Lansweeper INFO DateTimeService time refresh
by  miharix   Go to last post Go to first unread
Last post: 6/18/2021 10:48:57 AM(UTC)
Lansweeper RPC Unavailable error
by  Greeno  
Go to last post Go to first unread
Last post: 6/17/2021 7:15:07 PM(UTC)
Lansweeper Exclude Search
by  pryan67  
Go to last post Go to first unread
Last post: 6/16/2021 4:01:43 PM(UTC)
Lansweeper Report: All Apple Mac devices with Memory RAM asset
by  gabrielo   Go to last post Go to first unread
Last post: 6/16/2021 3:17:24 PM(UTC)
Lansweeper Does technical support for LS really respond?
by  tosch  
Go to last post Go to first unread
Last post: 6/16/2021 12:48:50 PM(UTC)