Notification

Icon
Error

Duplicate Users On report - Trying to create a report that show specific Microsoft installed Software.

Posted: Friday, October 30, 2020 2:19:09 PM(UTC)
Dexter Brooks

Dexter Brooks

Member Original PosterPosts: 1
0
Like
This issue has been solved! Click here to view the solution
Trying to create a report that show specific Microsoft installed Software. We are trying to report on operating systems and Office software, and a few other Microsoft programs like visual studio. We I put the report together it will pull show the same PC multiple time for the same piece of software.

Select Top 1000000 tblAssets.AssetID,
tblAssets.AssetName,
tblAssets.Username,
tsysOS.OSname,
tblSoftwareUni.softwareName As Software
From tblSoftware
Inner Join tblAssets On tblSoftware.AssetID = tblAssets.AssetID
Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID,
tsysOS
Where (tblSoftwareUni.softwareName Like '%Microsoft Office Standard%' Or
tblSoftwareUni.softwareName Like '%Microsoft Office Professional%')
Order By tblAssets.AssetName

Result

ATL-EDI-001 williamgristick Not scanned Microsoft Office Standard 2016
ATL-EDI-001 williamgristick Win 2016 Microsoft Office Standard 2016
ATL-EDI-001 williamgristick Win 10 Microsoft Office Standard 2016
ATL-EDI-001 williamgristick Win 10 Microsoft Office Standard 2016
ATL-EDI-001 williamgristick Win 2016 Microsoft Office Standard 2016
ATL-EDI-001 williamgristick Win 10 Microsoft Office Standard 2016
Dexter Brooks attached the following image(s):
Capture.JPG
RC62N
#1RC62N Member Posts: 488  
posted: 10/30/2020 3:51:07 PM(UTC)
You don't have a relationship defined between tsysOS and anything else, so your results are repeated for every record in tsysOS.
Code:
From
  tblSoftware
  Inner Join tblAssets On tblSoftware.AssetID = tblAssets.AssetID
  Inner Join tblSoftwareUni On tblSoftware.softID = tblSoftwareUni.SoftID
  INNER JOIN tsysOS ON tsysOS.OSCode = tblAssets.OScode

Active Discussions

Lansweeper Software deployment initiated by user
by  LS_enthusiast_4444  
Go to last post Go to first unread
Last post: Yesterday at 9:28:18 PM(UTC)
Lansweeper Help Desk not disabling for regular users?
by  FrankSc   Go to last post Go to first unread
Last post: Yesterday at 8:18:38 PM(UTC)
Lansweeper Satisfaction Questionnaire after ticket close
by  mouaad  
Go to last post Go to first unread
Last post: Yesterday at 4:31:44 PM(UTC)
Lansweeper Microsoft EDGE browser support
by  Vapoured   Go to last post Go to first unread
Last post: Yesterday at 4:54:30 AM(UTC)
Lansweeper Asset Management - Unattached assets
by  MrDiamond  
Go to last post Go to first unread
Last post: 11/25/2020 8:15:16 PM(UTC)
Lansweeper Lansweeper Fresh Install Hanging, High CPU, Unusable
by  ebars   Go to last post Go to first unread
Last post: 11/24/2020 7:53:38 PM(UTC)
Lansweeper Forwarding tickets to regular email recipents
by  ChristerT  
Go to last post Go to first unread
Last post: 11/24/2020 9:48:15 AM(UTC)