Notification

Icon
Error

Windows 10 Upgrade to 2004 - (From any version)

Posted: Thursday, August 13, 2020 1:18:01 PM(UTC)
Alex Beaumier

Alex Beaumier

Member Original PosterPosts: 6
1
Like
This issue has been solved! Click here to view the solution
Hello,

Have anyone tried to deploy the 2004 patch using Lansweeper using the Windows 10 ISO file (without re-downloading the whole image)? I've been trying multiple methods and I think I have the wrong arguments to use.

I need to push this update to multiple PCs at the same time (We're talking about 50 computers) without using SCCM or MDT, only Lansweeper (script-like method) and without the need to check for new updates (Just using the setup file in the ISO)

Arguments I used:
start /wait {PackageShare}\Installers\Windows10-2004-x64\x64\setup.exe /Auto Upgrade /DynamicUpdate Disable /Compat

Thank you,
CyberCitizen
#1CyberCitizen Member Posts: 471  
posted: 8/14/2020 8:47:16 AM(UTC)
I will be doing some testing next week on this as most of our fleet are 1909 getting ready to update to 2004, however we norrmaly hold off for a bit first to iron out any bugs etc. I have a few new machines to build shortly our image is only 1909 but I will build it then attempt an update and let you know if someone has't come back to you before then.
Alex Beaumier
#2Alex Beaumier Member Original PosterPosts: 6  
posted: 8/25/2020 3:30:10 PM(UTC)
Originally Posted by: Alex Beaumier Go to Quoted Post
Hello,

Have anyone tried to deploy the 2004 patch using Lansweeper using the Windows 10 ISO file (without re-downloading the whole image)? I've been trying multiple methods and I think I have the wrong arguments to use.

I need to push this update to multiple PCs at the same time (We're talking about 50 computers) without using SCCM or MDT, only Lansweeper (script-like method) and without the need to check for new updates (Just using the setup file in the ISO)

Arguments I used:
start /wait {PackageShare}\Installers\Windows10-2004-x64\x64\setup.exe /Auto Upgrade /DynamicUpdate Disable /Compat

Thank you,


Solution:
-Parameters:"{Packageshare}\Installers\Windows10-2004-x64\x64\setup.exe" /auto upgrade /quiet
-Windows currently installed language and downloaded ISO language have to be the same.

Active Discussions

Lansweeper Exclude non-windows assets from scanning by assetname
by  rapheren   Go to last post Go to first unread
Last post: Today at 1:18:12 PM(UTC)
Lansweeper HTTPS Certifikate untrusted
by  pskup  
Go to last post Go to first unread
Last post: Today at 9:20:07 AM(UTC)
Lansweeper Migrate to new host but without SQL
by  pskup   Go to last post Go to first unread
Last post: Today at 9:03:14 AM(UTC)
Lansweeper Object reference error after updating to 10.2.0.0
by  Erik.T  
Go to last post Go to first unread
Last post: Today at 8:10:25 AM(UTC)
Lansweeper Detect Docking Stations
by  CyberCitizen   Go to last post Go to first unread
Last post: Today at 12:59:42 AM(UTC)
Lansweeper Custom reporting - Asset Groups and AD Description
by  rbshawn  
Go to last post Go to first unread
Last post: Yesterday at 10:54:10 PM(UTC)
Lansweeper A FIX for an odd Scan Error WMI/DCOM from scanning server
by  danielm   Go to last post Go to first unread
Last post: Yesterday at 10:14:44 PM(UTC)
Lansweeper Purging helpdesk tickets older than 5 years
by  SentryP  
Go to last post Go to first unread
Last post: Yesterday at 6:13:37 PM(UTC)