Notification

Icon
Error

Database size growing too large

Posted: Wednesday, March 4, 2020 3:17:02 PM(UTC)
Anthony.M

Anthony.M

Member Original PosterPosts: 9
2
Like
My database seems to have grown exponentially over the last few weeks despite not gaining that many new assets:

Microsoft SQL Server 2014 (SP3) (KB4022619) - 12.0.6024.0 (X64) Sep 7 2018 01:37:51 Copyright (c) Microsoft Corporation Express Edition (64-bit) on Windows NT 6.3 <X64> (Build 18363: )
Database: lansweeperdb
Server: (localdb)\.\LSInstance
Schema Version: 231
Assets: 1603
Size: 8874.50 MB
Unallocated: 351.75 MB

My biggest table is:
Table Total Rows Reserved (KB) Data Size (KB) Index Size (KB) Unused Size (KB)
tblAssetJournal 8698667 7800568 7774576 24728 1264

I have done compact/shrink from database maintenance tool.

Any ideas what has happened?
RKCar
#1RKCar Member Posts: 82  
posted: 3/4/2020 3:45:58 PM(UTC)
Have you queried that table to see what is in there? I found something that said it used with the Enterprise Edition, which I do not have installed.
Anthony.M
#2Anthony.M Member Original PosterPosts: 9  
posted: 3/4/2020 4:13:03 PM(UTC)
I have an extremely limited knowledge of SQL so when I ran a query through Management Studio I didnt see anything offhand I could recognize as an issue.
RKCar
#3RKCar Member Posts: 82  
posted: 3/4/2020 4:39:23 PM(UTC)
Are there timestamps associated to the entries in that table? Maybe you can identify what the entries looked like prior to you noticing this uptick and see if there is something new populating that wasn't previously.

In the end you might have to contact support directly on this one. If it is related to Enterprise they may have made a chance on the cloud side that resulted in additional data populating this table.
GulfMarco
#4GulfMarco Member Posts: 12  
posted: 3/5/2020 3:10:11 AM(UTC)
Mine has, too. Interesting. I'm also trying Enterprise.
chris.anderson
#5chris.anderson Member Posts: 7  
posted: 5/21/2020 4:19:58 PM(UTC)
I ran into the same issue. Though now i have turned off the Enterprise connection but the table still grows like crazy. I just keep having to go in and delete all the records from the table. Not sure why it is still being used if the Enterprise option is turned off.
GulfMarco
#6GulfMarco Member Posts: 12  
posted: 5/21/2020 4:23:47 PM(UTC)
I turned off and deleted the enterprise setup, only then did the database stop growing. Mine never fully sync'ed up, and database grew to 30+ GB weekly or bi-weekly, crashing the servers.
ldockery
#7ldockery Member Posts: 4  
posted: 6/3/2020 3:20:44 PM(UTC)
Originally Posted by: GulfMarco Go to Quoted Post
I turned off and deleted the enterprise setup, only then did the database stop growing. Mine never fully sync'ed up, and database grew to 30+ GB weekly or bi-weekly, crashing the servers.


How did you delete the enterprise setup?
bladd
#8bladd Member Posts: 2  
posted: 6/5/2020 4:26:44 PM(UTC)
I'm having this same issue, trying to DELETE FROM tblAssetJournal; but it filled up my log disk overnight and failed. Wondering if it's safe to Drop that table completely, have asked support. I can't get the Enterprise options page to come up to disable it either.

Originally Posted by: Anthony.M Go to Quoted Post
My database seems to have grown exponentially over the last few weeks despite not gaining that many new assets:

Microsoft SQL Server 2014 (SP3) (KB4022619) - 12.0.6024.0 (X64) Sep 7 2018 01:37:51 Copyright (c) Microsoft Corporation Express Edition (64-bit) on Windows NT 6.3 <X64> (Build 18363: )
Database: lansweeperdb
Server: (localdb)\.\LSInstance
Schema Version: 231
Assets: 1603
Size: 8874.50 MB
Unallocated: 351.75 MB

My biggest table is:
Table Total Rows Reserved (KB) Data Size (KB) Index Size (KB) Unused Size (KB)
tblAssetJournal 8698667 7800568 7774576 24728 1264

I have done compact/shrink from database maintenance tool.

Any ideas what has happened?


Active Discussions

Lansweeper NOT doesn't work as expected
by  KevinA-REJIS   Go to last post Go to first unread
Last post: Yesterday at 5:49:29 PM(UTC)
Lansweeper Combined Vulnerability Report Q1 2019
by  Leslie Stroobant  
Go to last post Go to first unread
Last post: Yesterday at 3:27:42 PM(UTC)
Lansweeper All Devices with WINS Service Running on the Network
by  Andy.S   Go to last post Go to first unread
Last post: Yesterday at 2:44:56 PM(UTC)
Lansweeper Physical Laptops and Desktops Only
by  pryan67  
Go to last post Go to first unread
Last post: Yesterday at 1:51:56 PM(UTC)
Lansweeper Assistance With AV & Bitlocker Report
by  Andy.S   Go to last post Go to first unread
Last post: Yesterday at 12:50:47 PM(UTC)
Lansweeper Count of completed KB installation Report
by  jamie21  
Go to last post Go to first unread
Last post: 6/4/2020 11:49:57 AM(UTC)
Lansweeper local admin users of a specific device
by  Andy.S   Go to last post Go to first unread
Last post: 6/4/2020 10:42:23 AM(UTC)
Lansweeper Bitlocker Report not contain all computers
by  Andy.S  
Go to last post Go to first unread
Last post: 6/3/2020 6:20:53 PM(UTC)