Notification

Icon
Error

Do not show the computers that have a specific user

Posted: Tuesday, October 15, 2019 10:21:45 AM(UTC)
akuc

akuc

Member Original PosterPosts: 1
0
Like
I am trying to create a report that will show computers that do not contain the user "localadmin". Since there are more than one user on the computer, it shows even those computers on which there is a "localadmin" user. I do not understand how to filter this.

Quote:

Select Distinct Top 1000000 tsysOS.Image As icon,
tblAssets.AssetID,
tblAssets.AssetName,
tblAssets.Domain,
tblAssets.Username,
tblAssets.Userdomain,
tblAssets.IPAddress
From tblAssets
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tsysOS On tsysOS.OScode = tblAssets.OScode
Inner Join tblUsers On tblAssets.AssetID = tblUsers.AssetID
Inner Join tblOperatingsystem On
tblAssets.AssetID = tblOperatingsystem.AssetID
Where tblAssetCustom.State = 1 And tblUsers.Name != 'Localadmin' And
tblOperatingsystem.ProductType = '1'
Order By tblAssets.Domain,
tblAssets.AssetName

Active Discussions

Lansweeper Hyper-V guests dissapeared and reappeared
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:30:47 PM(UTC)
Lansweeper DB cleanup script
by  William382  
Go to last post Go to first unread
Last post: Yesterday at 4:23:43 PM(UTC)
Lansweeper Installing MS KB with Deploy
by  Esben.D   Go to last post Go to first unread
Last post: Yesterday at 4:01:45 PM(UTC)
Lansweeper Ticket Info Meter incorrect
by  pfalls  
Go to last post Go to first unread
Last post: Yesterday at 3:27:44 PM(UTC)
Lansweeper Asset Checkboxes in reports
by  ufficioced   Go to last post Go to first unread
Last post: Yesterday at 1:22:17 PM(UTC)
Lansweeper Silent "Run as logged in user" option
by  CyberCitizen  
Go to last post Go to first unread
Last post: Yesterday at 3:45:25 AM(UTC)
Lansweeper New ticket creation not emailing the user
by  MVMIC IT LANSWEEPER   Go to last post Go to first unread
Last post: 11/15/2019 5:36:23 PM(UTC)