Notification

Icon
Error

PR_CONNECT_RESET_ERROR when trying to connect via HTTPS - Followed the instructions. Why is my result bad?

Posted: Wednesday, September 11, 2019 3:52:57 PM(UTC)
foryouarecrunchy

foryouarecrunchy

Member Original PosterPosts: 2
0
Like
This issue has been solved! Click here to view the solution
Followed instructions outlined here: https://www.lansweeper.c...gure-ssl-in-iis-express/

1. Didn't change default http and https ports. (Still 81 and 82 respectively)

2. Imported the wildcard certificate that I would like to use to both the "Local Machine" certificate store and "Current User" certificate store under (Personal > Certificates).

3. Grabbed the thumprint and put it in the correct fileds in "Program Files (x86)\Lansweeper\IISexpress\IISExpressSvc.exe.config"

4. Changed the UseCustomSSLCertificate value to 1 in the same file.

5. Started IISExpress. HTTP site works, HTTPS site gives me this error in FF:

foryouarecrunchy attached the following image(s):
errorff.PNG
foryouarecrunchy
#1foryouarecrunchy Member Original PosterPosts: 2  
posted: 9/11/2019 5:41:22 PM(UTC)
Figured it out. Was an issue with the encoding of the thumbprint string I copy/pasted from the dialog.

If you get the same issue, you'll have these entries in your log.

Time: 11/09/2019 09:22:50 - Result: === Start ===
Time: 11/09/2019 09:22:50 - Result: ADD Custom URL - Port: 82
Time: 11/09/2019 09:22:50 - Result: Error Performing Commands. System.FormatException: Could not find any recognizable digits. at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos) at System.Convert.ToByte(String value, Int32 fromBase) at SslCertBinding.Net.CertificateBindingConfiguration.GetHash(String thumbprint) at SslCertBinding.Net.CertificateBindingConfiguration.<>c__DisplayClass1_0.<Bind>b__0() at SslCertBinding.Net.HttpApi.CallHttpApi(Action body) at SslCertBinding.Net.CertificateBindingConfiguration.Bind(CertificateBinding binding) at IISExpressSvc.ServiceStart.PerformCommands(String thumbPrint, Boolean isCustom, Boolean debug)

Active Discussions

Lansweeper Drive Encryption statuses
by  JacobH   Go to last post Go to first unread
Last post: Yesterday at 5:41:10 PM(UTC)
Report Center Local admin group report based on domain role
by  JacobH  
Go to last post Go to first unread
Last post: Yesterday at 5:24:13 PM(UTC)
Lansweeper Number of scanned IPs
by  wayneRex   Go to last post Go to first unread
Last post: Yesterday at 10:21:01 AM(UTC)
Lansweeper Ticket Summary by Agent?
by  susan.starr  
Go to last post Go to first unread
Last post: 9/17/2019 4:41:26 PM(UTC)
Report Center Virtual machines and their host
by  klaus   Go to last post Go to first unread
Last post: 9/17/2019 8:44:57 AM(UTC)
Lansweeper Patch Tuesday report, last 3 months
by  Esben.D  
Go to last post Go to first unread
Last post: 9/16/2019 1:38:33 PM(UTC)
Lansweeper Query on 'Assets: Installed software by computer' Report
by  RC62N   Go to last post Go to first unread
Last post: 9/12/2019 5:12:40 PM(UTC)
Lansweeper Adding Comments
by  AZHockeyNut  
Go to last post Go to first unread
Last post: 9/10/2019 7:39:40 PM(UTC)