PR_CONNECT_RESET_ERROR when trying to connect via HTTPS - Followed the instructions. Why is my result bad?

Posted: Wednesday, September 11, 2019 3:52:57 PM(UTC)


Member Original PosterPosts: 2
This issue has been solved! Click here to view the solution
Followed instructions outlined here: https://www.lansweeper.c...ure-ssl-in-iis-express/

1. Didn't change default http and https ports. (Still 81 and 82 respectively)

2. Imported the wildcard certificate that I would like to use to both the "Local Machine" certificate store and "Current User" certificate store under (Personal > Certificates).

3. Grabbed the thumprint and put it in the correct fileds in "Program Files (x86)\Lansweeper\IISexpress\IISExpressSvc.exe.config"

4. Changed the UseCustomSSLCertificate value to 1 in the same file.

5. Started IISExpress. HTTP site works, HTTPS site gives me this error in FF:

foryouarecrunchy attached the following image(s):
#1foryouarecrunchy Member Original PosterPosts: 2  
posted: 9/11/2019 5:41:22 PM(UTC)
Figured it out. Was an issue with the encoding of the thumbprint string I copy/pasted from the dialog.

If you get the same issue, you'll have these entries in your log.

Time: 11/09/2019 09:22:50 - Result: === Start ===
Time: 11/09/2019 09:22:50 - Result: ADD Custom URL - Port: 82
Time: 11/09/2019 09:22:50 - Result: Error Performing Commands. System.FormatException: Could not find any recognizable digits. at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos) at System.Convert.ToByte(String value, Int32 fromBase) at SslCertBinding.Net.CertificateBindingConfiguration.GetHash(String thumbprint) at SslCertBinding.Net.CertificateBindingConfiguration.<>c__DisplayClass1_0.<Bind>b__0() at SslCertBinding.Net.HttpApi.CallHttpApi(Action body) at SslCertBinding.Net.CertificateBindingConfiguration.Bind(CertificateBinding binding) at IISExpressSvc.ServiceStart.PerformCommands(String thumbPrint, Boolean isCustom, Boolean debug)
#2FBBCIT Member Posts: 2  
posted: 10/28/2019 9:29:01 PM(UTC)
Could you give detail as to the encoding or what to do to fix this error? I am running into the same issue.

#3FBBCIT Member Posts: 2  
posted: 10/28/2019 9:48:19 PM(UTC)
I now have it working. After multiple attempts before posting, I tried the following after posting my question and this worked:

Instead of copying the thumbprint straight from the certificate into the config file:

1) Copy the thumbprint to a new notepad document.
2) Use Replace to remove all of the spaces.
3) Copy the newly edit line of text.
4) Open the IISExpressSvc.exe.config file using Programmer's Notepad and paste the copied text into the config file.
5) Restart the IIS Express service.
#4Esben.D Member Administration Posts: 1,977  
posted: 10/29/2019 9:19:42 AM(UTC)
Good to see you found it. Thanks for posting the solution.

Active Discussions

Lansweeper Report on clients with no LSAgent
by  RobertB   Go to last post Go to first unread
Last post: Yesterday at 6:55:32 PM(UTC)
Lansweeper Lansweeper report to match computer name
by  RC62N   Go to last post Go to first unread
Last post: 2/19/2020 5:02:27 PM(UTC)
Lansweeper Distinct user logins per PC
by  Bruce Garoutte   Go to last post Go to first unread
Last post: 2/17/2020 6:36:29 PM(UTC)
Lansweeper Software version report issue
by  RC62N  
Go to last post Go to first unread
Last post: 2/17/2020 4:07:20 PM(UTC)
Lansweeper Patch Tuesday - Exclude Win 2008 & Win7
by  doone128   Go to last post Go to first unread
Last post: 2/17/2020 1:34:36 PM(UTC)
Lansweeper Performance statistics combined into one report
by  djs1789  
Go to last post Go to first unread
Last post: 2/15/2020 1:50:32 AM(UTC)