Notification

Icon
Error

dotNET framework 3.5 deployment

Posted: Monday, July 1, 2019 10:33:03 AM(UTC)
TCI

TCI

Member Original PosterPosts: 3
0
Like
On each version update of Windows we face a similar challenge d'oh!
We created a command to install the .NET 3.5 in Windows 10 v 1906.

Quote:
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart


On Windows v1809 this was still working.
However on v1906 the deployment fails due to lack of elevated permissions.
We always install with Scanning Credentials as this account is also local admin on all assets however
it seems DISM requires the NAME administrator for these elevated permissions.
The default account ADMINISTRATOR however is disabled by global company policy.

So if I run the above from a CMD box that was "run as administrator" it's working fine.
My question is: How can I run the same command from the Deployment screen in LANsweeper with these elevated permissions?

Kind regards
chrism010
#1chrism010 Member Posts: 2  
posted: 7/10/2019 3:22:47 PM(UTC)
Have you tried just running as system account? Thats what i run most of our deployments on since its basically god mode on computer.
Esben.D
#2Esben.D Member Administration Posts: 1,930  
posted: 7/12/2019 8:51:05 AM(UTC)
System account might indeed work.
Ramezi
#3Ramezi Member Posts: 6  
posted: 7/15/2019 3:49:15 PM(UTC)
Just curious how were you able to get this to script to install the complete 3.5 .net framework on a Win10, without any error messages.... error: 0x800F0906, 0x800F081F, 0x800F0907...
Using this script...
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart

Im running into errors listed above running it in PowerShell and CMD elevated...

Thank you..TCI

Active Discussions

Lansweeper Patch Tuesday report, last 3 months
by  JacobH   Go to last post Go to first unread
Last post: Today at 5:28:37 PM(UTC)
Lansweeper Report ALL office (ms officce,libreoffice,openoffice
by  AlexRus227  
Go to last post Go to first unread
Last post: Today at 8:37:07 AM(UTC)
Lansweeper Assets Missing Quickfix Data - Last 60 Days
by  Mike6436   Go to last post Go to first unread
Last post: Yesterday at 6:11:30 PM(UTC)
Lansweeper BlueKeep Vulnerability
by  jwood.mls  
Go to last post Go to first unread
Last post: Yesterday at 4:58:59 PM(UTC)
Lansweeper tblCPlogoninfo - None interactive logons?
by  Millslansweeper   Go to last post Go to first unread
Last post: 11/8/2019 1:32:12 PM(UTC)
Lansweeper Software : changes last 24 hours Enhancement
by  RC62N  
Go to last post Go to first unread
Last post: 11/7/2019 10:05:53 PM(UTC)
Lansweeper Adding Comments
by  CyberCitizen  
Go to last post Go to first unread
Last post: 11/5/2019 12:28:21 AM(UTC)