Notification

Icon
Error

Lansweeper warnings sent to an email

Posted: Tuesday, June 25, 2019 2:23:29 PM(UTC)
MilicaM

MilicaM

Member Original PosterPosts: 6
0
Like
Hi,

I have an alert displayed on Lansweeper web console: "License Warning | Your license is limited to 5000 assets. You've reached 95%".

Is there a possibility to receive this warning over an email? And when the assets count is below 95% no email warning is received.

Thank you,
Milica
Esben.D
#1Esben.D Member Administration Posts: 1,982  
posted: 7/12/2019 9:55:15 AM(UTC)
You could create a report about it and use it in a report alert:

Code:
Select Top 1000000 Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) As
  [%]
From tblAssets
  Left Join (Select tblAssets.AssetID
      From tblAssets
        Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
        Inner Join tsysAssetTypes On tsysAssetTypes.AssetType =
          tblAssets.Assettype
        Inner Join tblState On tblState.State = tblAssetCustom.State
      Where tblState.Statename != 'monitor') As SQ1 On SQ1.AssetID =
    tblAssets.AssetID
Having Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) >= 95
MilicaM
#2MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:07:02 AM(UTC)
Hi Esben,

Many thanks for your reply!

I already found solution:

Select Top 1000000 Count(tblAssets.AssetID) As [Asset count],
5000 As [Asset limit],
Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As decimal(8,2)) As
[% used]
From tblAssets
Where tblAssets.AssetUnique Not Like 'Mon:%'
Having Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As
decimal(8,2)) >= 95

Where 5000 is asset limit.

Regards,
Milica
Esben.D
#3Esben.D Member Administration Posts: 1,982  
posted: 7/12/2019 10:16:37 AM(UTC)
You will still have to take into account that Monitor assets are not counted towards the license. So you will have to slightly adjust your report.
MilicaM
#4MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:36:44 AM(UTC)
Hey Esben, thanks for noticed it, but I already put the filter with:

Where tblAssets.AssetUnique Not Like 'Mon:%' :)

Milica

Active Discussions

Lansweeper Only 1 Basic Action not working?
by  DotWAD   Go to last post Go to first unread
Last post: Yesterday at 6:17:05 PM(UTC)
Lansweeper Mapped Drives Incorrect
by  cycleheat  
Go to last post Go to first unread
Last post: Yesterday at 5:21:32 PM(UTC)
Lansweeper Help on creating report list from security groups
by  sc00bs   Go to last post Go to first unread
Last post: Yesterday at 4:52:39 PM(UTC)
Lansweeper Will someone at Lansweeper please take my money?
by  sbAYVdQu  
Go to last post Go to first unread
Last post: Yesterday at 3:31:33 PM(UTC)
Lansweeper Monitor open process
by  Renato   Go to last post Go to first unread
Last post: Yesterday at 3:10:48 PM(UTC)
Lansweeper Duplicate assets (Servers)
by  kjstech  
Go to last post Go to first unread
Last post: Yesterday at 2:34:14 PM(UTC)
Lansweeper Office 365 32bit vs 64bit?
by  CyberCitizen   Go to last post Go to first unread
Last post: Yesterday at 7:22:38 AM(UTC)
Lansweeper "add cc user" doesn't show the correct listings
by  JLPingree  
Go to last post Go to first unread
Last post: 7/6/2020 8:12:44 PM(UTC)