Notification

Icon
Error

User association report query - List all Active Directory users that don't have an asset of type X associated

Posted: Monday, June 24, 2019 5:38:51 PM(UTC)
dan508

dan508

Member Alpha Tester Original PosterPosts: 3
0
Like
Hi all.
slowly learning SQL, and I need a bit of assistance on this one query.
I want to query all Active directory users that don't have an asset of type 909 assigned to them. To do this, I have the following script, but it isn't working :(

select username
from tblADusers
where not exists
(select tbladusers.username
,tblAssetUserRelations.AssetID
,tblassets.Assettype

from tblADusers
inner join tblassetuserrelations on tbladusers.username=tblassetuserrelations.username
inner join tblAssets on tblAssetuserrelations.AssetID=tblAssets.AssetID
where tblassets.assettype =909
)


If I run the sub Query, it pull in all AD users that do have asset type 909 assigned to them. so shouldn't it be as simple as running a query to pull the user that aren't in the sub query?

Any help will be appreciated.

Thanks in advanceBrick wall ,
Dan
endyk
#1endyk Member Posts: 24  
posted: 6/26/2019 9:47:25 PM(UTC)
Hello Dan,

I think this should do it for you.

SELECT tbladusers.username,
tblAssetUserRelations.AssetID,
tblassets.Assettype
FROM tblADusers
INNER JOIN tblassetuserrelations ON tbladusers.username=tblassetuserrelations.username
INNER JOIN tblAssets ON tblAssetuserrelations.AssetID=tblAssets.AssetID
WHERE tblassets.assettype <> 909

Active Discussions

Lansweeper Only 1 Basic Action not working?
by  DotWAD   Go to last post Go to first unread
Last post: Yesterday at 6:17:05 PM(UTC)
Lansweeper Mapped Drives Incorrect
by  cycleheat  
Go to last post Go to first unread
Last post: Yesterday at 5:21:32 PM(UTC)
Lansweeper Help on creating report list from security groups
by  sc00bs   Go to last post Go to first unread
Last post: Yesterday at 4:52:39 PM(UTC)
Lansweeper Will someone at Lansweeper please take my money?
by  sbAYVdQu  
Go to last post Go to first unread
Last post: Yesterday at 3:31:33 PM(UTC)
Lansweeper Monitor open process
by  Renato   Go to last post Go to first unread
Last post: Yesterday at 3:10:48 PM(UTC)
Lansweeper Duplicate assets (Servers)
by  kjstech  
Go to last post Go to first unread
Last post: Yesterday at 2:34:14 PM(UTC)
Lansweeper Office 365 32bit vs 64bit?
by  CyberCitizen   Go to last post Go to first unread
Last post: Yesterday at 7:22:38 AM(UTC)
Lansweeper "add cc user" doesn't show the correct listings
by  JLPingree  
Go to last post Go to first unread
Last post: 7/6/2020 8:12:44 PM(UTC)