Notification

Icon
Error

Windows Activation - Is there a windows activation report

Posted: Wednesday, May 1, 2019 7:23:54 PM(UTC)
pfenton

pfenton

Member Original PosterPosts: 27
0
Like
Has anybody written a report that lists windows activation status?
endyk
#1endyk Member Posts: 25  
posted: 5/17/2019 10:39:03 AM(UTC)
Hello,

I found one that I slightly modified. Hope it helps.

Code:

Select Top 1000000
    Case
        When tblComputersystem.Domainrole > 1 Then
            'Server'
        Else
            Case
                When Coalesce(tblPortableBattery.AssetID, 0) = 0 Then
                    'Desktop'
                Else
                    'Laptop'
            End
    End                           As Type
  , tblOperatingsystem.Caption    As Operatingsystem
  , tblAssetCustom.Manufacturer   As Vendor
  , tsysAssetTypes1.AssetTypename As [Asset Type]
  , tblAssetCustom.Model
  , tblAssets.AssetUnique
  , tblAssetCustom.Serialnumber   As [Service Tag Number]
  , tblAssetCustom.Custom5        As AssetTag
  , tblAssetCustom.Contact        As [Allocated ID]
  , tblADusers.Displayname
  , tblState.Statename            As [Asset state]
  , tblAssetCustom.Custom3        As [PO Number]
  , tblAssetCustom.PurchaseDate
  , tblAssetCustom.Warrantydate   As [Warranty End Date]
  , tblAssetCustom.Custom2        As [Invoice number]  
  , tblAssets.Domain
  , tblAssetCustom.AssetID
  , tblAssets.Lastseen
From tblAssetCustom
    Inner Join tblAssets
        On tblAssetCustom.AssetID = tblAssets.AssetID
    Inner Join tblOperatingsystem
        On tblAssets.AssetID = tblOperatingsystem.AssetID
    Inner Join tsysAssetTypes    tsysAssetTypes1
        On tsysAssetTypes1.AssetType = tblAssets.Assettype
    Inner Join tblAssetGroupLink
        On tblAssets.AssetID = tblAssetGroupLink.AssetID
    Inner Join tblAssetGroups
        On tblAssetGroups.AssetGroupID = tblAssetGroupLink.AssetGroupID
    Inner Join tsysAssetTypes
        On tsysAssetTypes.AssetType = tblAssets.Assettype
    Left Join tblADusers
        On tblADusers.Username = tblAssets.Username
           And tblADusers.Userdomain = tblAssets.Userdomain
    Left Join tsysIPLocations
        On tblAssets.IPNumeric >= tsysIPLocations.StartIP
           And tblAssets.IPNumeric <= tsysIPLocations.EndIP
    Inner Join tblComputersystem
        On tblAssets.AssetID = tblComputersystem.AssetID
    Left Join tblPortableBattery
        On tblAssets.AssetID = tblPortableBattery.AssetID
    Inner Join tblState
        On tblAssetCustom.State = tblState.State
Where tsysAssetTypes1.AssetTypename = 'Windows'
      And tblAssetCustom.State = 1
Order By tblAssets.AssetName
cesar.ti
#2cesar.ti Member Posts: 2  
posted: 5/19/2020 2:26:02 PM(UTC)
it didn't work took all of them as activated
EtienneB
#3EtienneB Member Posts: 1  
posted: 4/16/2021 3:42:49 PM(UTC)
Hi.
Also not working for me.
Showing all the assets on the report.
Hendrik.VE
#4Hendrik.VE Member Posts: 81  
posted: 4/16/2021 4:01:47 PM(UTC)
Didn't try this out yet, but you could create a deployment package that runs the following PowerShell command:
$WinVerAct = (cscript /Nologo "C:\Windows\System32\slmgr.vbs" /xpr) -join ''

Write this into a custom registry key, and scan the registry key with Lansweeper.

New-Item –Path "HKLM:\Winact" –Name Activation

New-ItemProperty -Path "HKLM:\Winact\Activation" -Name "Winveract" -Value $WinVerAct -PropertyType "String"


Then create an appropriate report.

Something like that :-)

Active Discussions

Lansweeper Using tblO365User report for devices Out of warranty
by  QueryLSTech   Go to last post Go to first unread
Last post: Yesterday at 5:15:37 PM(UTC)
Lansweeper Duplicate assets, random monitor unique keys
by  kloosterd  
Go to last post Go to first unread
Last post: Yesterday at 1:00:34 PM(UTC)
Lansweeper Scanning - nothing appears in the queue
by  LS IT Admins   Go to last post Go to first unread
Last post: Yesterday at 11:08:22 AM(UTC)
Lansweeper Broken scanning of AD
by  LS IT Admins  
Go to last post Go to first unread
Last post: Yesterday at 10:59:35 AM(UTC)
Lansweeper New ticket auto-assignment & default state
by  Brandon   Go to last post Go to first unread
Last post: 5/13/2021 5:21:31 PM(UTC)
Lansweeper Automatic Follow-Up for Tickets
by  Francis Lee Mondia - Endace  
Go to last post Go to first unread
Last post: 5/12/2021 11:06:51 PM(UTC)
Lansweeper Can't see devices on Lansweeper
by  vqT4cDoP9iXyMZwoDUWU   Go to last post Go to first unread
Last post: 5/12/2021 8:33:21 PM(UTC)
Lansweeper LAPS managed password
by  SystemAdmin  
Go to last post Go to first unread
Last post: 5/12/2021 6:08:42 PM(UTC)