Notification

Icon
Error

All Widget configuration is grayed out - General widget question, not a custom widgets question

Posted: Thursday, October 27, 2016 2:17:58 PM(UTC)
Mike6436

Mike6436

Member Original PosterPosts: 34
0
Like
I would like to make certain widgets available to my users as well as remove some but they are all grayed out. Please see the attached screenshot.

I am using an administrator account.

Is there something I can do to make them "active" or is this by design? If it is by design, what is the reasoning?

Thanks!

Mike6436 attached the following image(s):
Capture.JPG
Karel DS
#1Karel DS Member Lansweeper Developer Administration Posts: 202  
posted: 10/28/2016 3:40:35 PM(UTC)
This is indeed by design, you're not supposed to edit these settings for built-in widgets as this might break the way they work. With custom widgets you can do what you want. Can edit means the widget has fields which can be filled in, and stay filled in after leaving the website (for example to select a specific report or add a specific link to an iframe widget). Not shown in the helpdesk is for widgets which aren't supposed to be visible to people who are only agents and don't have access to the asset management part of Lansweeper. Webpage is the physical location of the widget's webpage inside the Lansweeper folder. It is also possible these options might change in the future, so users changing these settings might also conflict with that.

So, your options are (next to the permissions to show helpdesk or deployment tables in reports):
  • Users that have access to asset management will see all widgets
  • Agents who don't have asset management access will only see helpdesk widgets
  • User who aren't an agent and don't have access to asset management currently can't use any widgets

We might add more options in the future, for example some widgets which all users can see.
Mike6436
#2Mike6436 Member Original PosterPosts: 34  
posted: 10/28/2016 5:01:35 PM(UTC)
Karel,

Thanks for that explanation. That helps greatly. However, I have a user who has access to asset management but cannot see all of the widgets. For instance, the News widget (not the Lansweeper news widget). It doesn't even appear under the "+Add Widgets" section.

I am sure I am just missing something but, I am not sure what.

Do you have any suggestions?

Thanks!
Karel DS
#3Karel DS Member Lansweeper Developer Administration Posts: 202  
posted: 11/10/2016 11:12:19 AM(UTC)
If the user is not an agent then he won't be able to see a bunch of helpdesk widgets (ex. Events, Helpdesk Report ...). This is normal.

The widget you're mentioning (Helpdesk news) not showing up seems to be a bug, however. We'll look into that.
Mike6436
#4Mike6436 Member Original PosterPosts: 34  
posted: 11/10/2016 5:14:06 PM(UTC)
Thank you! Please let me know if you need anything else from me.
Andrew W.
#5Andrew W. Member Posts: 5  
posted: 5/8/2018 4:28:08 PM(UTC)
Was there ever a resolution for this? I seem to be experiencing the same problem.

I want to be able to post news as described here: https://www.lansweeper.c...ith-the-news-widget.html . But I am not able to see "News" in the Add Widgets menu.

Thank you!
Andrew

Active Discussions

Lansweeper Install Adobe Reader Error
by  Brandon   Go to last post Go to first unread
Last post: Today at 3:25:07 PM(UTC)
Lansweeper End of Life Asset Report
by  Hendrik.VE  
Go to last post Go to first unread
Last post: Today at 2:18:23 PM(UTC)
Lansweeper Translation settings not saved
by  Brandon   Go to last post Go to first unread
Last post: Yesterday at 2:10:22 PM(UTC)
Lansweeper Combobox translation
by  sneagele  
Go to last post Go to first unread
Last post: Yesterday at 2:03:45 PM(UTC)
Lansweeper Freelance for Lansweeper Deploy?
by  Brandon   Go to last post Go to first unread
Last post: 5/7/2021 6:32:21 PM(UTC)
Lansweeper Installation issues
by  Richie_Rich  
Go to last post Go to first unread
Last post: 5/6/2021 11:29:09 PM(UTC)
Lansweeper Cloud relay data stored time
by  Richie_Rich   Go to last post Go to first unread
Last post: 5/6/2021 11:14:42 PM(UTC)
Lansweeper Custom attributes from AD
by  dhoward  
Go to last post Go to first unread
Last post: 5/6/2021 11:10:45 PM(UTC)