Notification

Icon
Error

Another AV report request

Posted: Friday, February 26, 2016 8:31:42 PM(UTC)
jmje

jmje

Member Posts: 18
0
Like
This issue has been solved! Click here to view the solution
Hi, I've been trying to get a report that will show me if a machine doesn't have the current Symantec Endpoint protection installed. I have it showing me ANY antivirus that is out of date, but that's part of the problem.

I'd like a few reports in the end that give me these specifics :

1) Symantec Endpoint Protection, out of date or disabled.
2) More than 1 Antivirus product installed.
3) No Antivirus installed. (Already have, and it appears to work fine.)

I work in a multi-domain environment, so if I can get the following in the report, that'd be great.

1) Asset name
2) domain
3) IP Address
4) Antivirus enabled/disabled, version of signature file if out of date, etc... as appropriate for the 3 reports above.

Thanks in advance. I'm apparently pretty bad at sql queries, and we're a small IT shop without SQL programmers, so it's been hard going.

J
ict-user
#1ict-user Member  
posted: 2/29/2016 9:59:32 AM(UTC)
1:
Select Top 1000000 tblAssets.AssetID,
tblAssets.AssetName,
tsysAssetTypes.AssetTypename,
tsysAssetTypes.AssetTypeIcon10 As icon,
tblAssets.IPAddress,
tblAssets.Lastseen,
tblAssets.Lasttried,
tblAntivirus.DisplayName As Antivirus
From tblAssets
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
Inner Join tblAntivirus On tblAssets.AssetID = tblAntivirus.AssetID
Where tblAntivirus.DisplayName Like '%Symantec%' And tblAssetCustom.State = 1
And tblAntivirus.productUpToDate = 0
Order By tblAssets.AssetName

jmje
#2jmje Member  
posted: 2/29/2016 2:08:57 PM(UTC)
Thanks much.

Is that "out of date" OR "disabled", though?
Looking at the results it's showing me assets with AV enabled that are out of date, but not devices that have AV disabled. Does this need to be 2 separate reports?

Thanks again!

J
ict-user
#3ict-user Member  
posted: 3/1/2016 1:47:04 PM(UTC)
out of date
jmje
#4jmje Member  
posted: 3/1/2016 2:59:24 PM(UTC)
Ok. Thank you. :)
Unhappymeal
#5Unhappymeal Member  
posted: 5/19/2017 5:23:52 PM(UTC)
Is there a way to add what the out of date def file is? i found the reg key and value.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Symantec\Symantec Endpoint Protection\CurrentVersion\public-opstate]
"LatestVirusDefsDate"="2017-05-19"

Active Discussions

Lansweeper Report for inventory
by  leblanc.daniel.4@hydro.qc.ca   Go to last post Go to first unread
Last post: Yesterday at 8:16:00 PM(UTC)
Lansweeper Project Management
by  jcait  
Go to last post Go to first unread
Last post: Yesterday at 6:34:20 PM(UTC)
Lansweeper lansweeper service not listening on port 9524
by  JDav007  
Go to last post Go to first unread
Last post: Yesterday at 2:35:01 PM(UTC)
Lansweeper WSUS Reports
by  Nick.VDB   Go to last post Go to first unread
Last post: Yesterday at 2:17:52 PM(UTC)
Lansweeper Help creating deployment package
by  MasterDoddy  
Go to last post Go to first unread
Last post: Yesterday at 11:22:24 AM(UTC)
Lansweeper Reminder email on Unasigned tickets
by  chris.anderson   Go to last post Go to first unread
Last post: 8/16/2017 5:47:37 PM(UTC)
Lansweeper AD tags
by  jkrelic  
Go to last post Go to first unread
Last post: 8/16/2017 5:26:37 PM(UTC)