Notification

Icon
Error

Custom Scanning - file not existing

Posted: Monday, October 12, 2015 7:16:51 AM(UTC)
koglerh

koglerh

Member Original PosterPosts: 21
2
Like
This issue has been solved! Click here to view the solution
I want to check certain clients if they DONT have a specific file installed. Whenever i want to scan FOR a file, i use custom scanning method. But in this case i wonder how i should proceed?

ps. i want to scan if a specific font is not installed (or at least not in the windows-font directory).

any ideas?
Daniel.B
#1Daniel.B Member Posts: 1,150  
posted: 10/12/2015 12:35:43 PM(UTC)
You can get a list of computers not having a specific file through a custom report by
  • setting up custom file scanning for this file (instructions can be found here)
  • rescanning all your Windows computers
  • running a report like the following example:
    Code:
    
    Select Top 1000000 tblAssets.AssetID,
      tblAssets.AssetName,
      tblAssets.IPAddress,
      tblAssets.Lastseen,
      tsysOS.OSname,
      tsysOS.Image As icon
    From tblAssets
      Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
      Inner Join tsysOS On tblAssets.OScode = tsysOS.OScode
    Where tblAssets.AssetID Not In (Select tblFileVersions.AssetID
      From tblFileVersions
      Where tblFileVersions.FilePathfull Like '%[h]Fonts\EXAMPLE.TTF[/h]' And
        tblFileVersions.Found = 'True') And tblAssetCustom.State = 1
    Order By tblAssets.AssetName
    
koglerh
#2koglerh Member Original PosterPosts: 21  
posted: 10/12/2015 1:47:11 PM(UTC)
Thanks Daniel! That's the perfect solution!
Bruce Garoutte
#3Bruce Garoutte Member Posts: 3  
posted: 7/17/2019 8:19:50 PM(UTC)
Daniel,
Brilliant!!
Thank you so much, this was exactly what we needed.

Active Discussions

Lansweeper how to add windows and office licenses manually.
by  cesar.ti   Go to last post Go to first unread
Last post: 8/23/2019 7:32:10 PM(UTC)
Lansweeper User roles and permissions
by  RKCar  
Go to last post Go to first unread
Last post: 8/23/2019 6:23:38 PM(UTC)
Lansweeper Deployment condition
by  RKCar   Go to last post Go to first unread
Last post: 8/23/2019 4:07:30 PM(UTC)
Lansweeper HP Printer not showing correctly
by  JacobH  
Go to last post Go to first unread
Last post: 8/23/2019 1:32:54 PM(UTC)
Lansweeper Moving Assets in Location not Saving
by  brodiemac   Go to last post Go to first unread
Last post: 8/23/2019 12:23:04 PM(UTC)
Lansweeper Scanning includes IOS devices even though I exclude them??
by  steveb  
Go to last post Go to first unread
Last post: 8/22/2019 11:05:33 PM(UTC)
Lansweeper lsagent not scanning/sending when using relay
by  Esben.D   Go to last post Go to first unread
Last post: 8/19/2019 12:31:02 PM(UTC)
Lansweeper Check if Netbios is disabled over TCP/IP
by  TaherMD  
Go to last post Go to first unread
Last post: 8/19/2019 6:00:51 AM(UTC)