Notification

Icon
Error

OS: Not latest Build of Windows 10 not working

Posted: Monday, October 18, 2021 12:48:41 PM(UTC)
jmm25

jmm25

Member Original PosterPosts: 3
0
Like
Since about a week and a half ago, the OS: Not Latest Build of Windows 10 report has been broken on my network. The only result it gives is:

Error: Conversion failed when converting the varchar value 'Linux' to data type int.

We have two CentOS machines on the network and they're not going away any time soon so we need to either find out how to fix this or how to create a new report that doesn't explode at the slightest hint that there are other OSes out there. Any suggestions?
Luke Maslany
#1Luke Maslany Member Posts: 3  
posted: 11/29/2021 2:01:49 PM(UTC)
Just curious, but is there any possibility there is a non-integer value in the tblassets.BuildNumber field of one of your assets?

Not sure how many assets you have, but a quick and dirty way could be to run the following as a new report and cast your eye over it:

Quote:
Select Top 1000000 tblassets.AssetID,
tblassets.AssetName,
tblassets.BuildNumber
From tblassets
Where tblassets.BuildNumber Is Not Null

Active Discussions

Lansweeper I can no longer scan my Windows assets
by  pflebus   Go to last post Go to first unread
Last post: Today at 5:11:40 PM(UTC)
Lansweeper Alert on New Host
by  swede  
Go to last post Go to first unread
Last post: Today at 7:53:52 AM(UTC)
Lansweeper Reports - Printers
by  AEckrich  
Go to last post Go to first unread
Last post: 6/24/2022 2:23:41 PM(UTC)
Lansweeper Network printers not detected as a printer?
by  Erik.T   Go to last post Go to first unread
Last post: 6/24/2022 1:06:47 PM(UTC)
Lansweeper Contact external mail / helpdesk - external mail
by  Wolfgang   Go to last post Go to first unread
Last post: 6/24/2022 7:46:19 AM(UTC)
Lansweeper Asset Check-in Check-out - Email Alert
by  hcssit@hcss.com  
Go to last post Go to first unread
Last post: 6/23/2022 8:42:55 PM(UTC)