Notification

Icon
Error

Cannot deploy .exe : FileNotFoundException - Clients seem to deploy file from wrong path

Posted: Wednesday, October 27, 2021 9:39:55 AM(UTC)
vince1098

vince1098

Member Original PosterPosts: 3
1
Like
Hello

Whenever I'm trying to deploy an executable on clients per Lansweeper deployment, I receive an "incorrect function" Error in the Deployment Logs.

The step is just "<path to exe>\program.exe". It neither works with local paths like %windir% nor with UNC paths.
When I go to the client I tried to deploy it on, I see these errors in the Windows Event Viewer:

(see attached images)

So I'm pretty sure it's not a permission error, since every other deployment, even those that require admin elevation, run fine with the same credentials.

It sais "FileNotFoundException". Is there a reason why in the error log it sais Faulting application path: C:\Users\VINCEN~1.BEY\AppData\Local\Temp\MW-ae47b2b4-1c52-4fbc-a727-164e1d26ae23\files\GooseDesktop.exe
?
The username in this path is altered (it should say vincent.beyer), and why is it even executing from the Temp path instead of the one I gave in the command deployment field?

Thanks for your help!
vince1098 attached the following image(s):
err1.PNG
err2.PNG
err3.PNG
prighi61
#1prighi61 Member Posts: 41  
posted: 10/28/2021 8:36:34 AM(UTC)
Hi vincet1098, maybe the executable needs an assembly (or another type of file) that is not present on the target pc. Have you tried to run it manually on the target pc?
vince1098
#2vince1098 Member Original PosterPosts: 3  
posted: 10/28/2021 12:41:40 PM(UTC)
Originally Posted by: prighi61 Go to Quoted Post
Hi vincet1098, maybe the executable needs an assembly (or another type of file) that is not present on the target pc. Have you tried to run it manually on the target pc?


Hello prighi61, thanks for your quick answer. Yes, running it manually with the same command on the machine works fine. I also tried embedding the command (which is just the path because it's just an .exe) in double qoutes ("path"), single quotes ('path') as well as no quotes, just in case Windows makes a difference between german and english OS.
prighi61
#3prighi61 Member Posts: 41  
posted: 10/28/2021 2:31:11 PM(UTC)
Hi vince1098,

I searched for the Desktop Goose "gadget" and found a 7zip SFX desktop-goose-0-3.exe.
Running it you extract the files (executable, dlls, and config file) needed to run the gadget.
I don't understand whether you want to install it from the SFX or want to make the extracted application auto-start on the remote pc when the user logs on.
In the latter case you shouldn't execute the application, but add it to an autostart mechanisms (Run registry or Startup menu folder).

vince1098
#4vince1098 Member Original PosterPosts: 3  
posted: 10/28/2021 4:45:55 PM(UTC)
Originally Posted by: prighi61 Go to Quoted Post
Hi vince1098,

I searched for the Desktop Goose "gadget" and found a 7zip SFX desktop-goose-0-3.exe.
Running it you extract the files (executable, dlls, and config file) needed to run the gadget.
I don't understand whether you want to install it from the SFX or want to make the extracted application auto-start on the remote pc when the user logs on.
In the latter case you shouldn't execute the application, but add it to an autostart mechanisms (Run registry or Startup menu folder).



Neither :D I just want to be able to remotely execute some programs when I see the need to, I don't want them to run permanently or at login or autostart or whatever. Just execute .exe files per lansweeper deployment. Doesn' even work with notepad.exe, which is installed locally on every PC.
prighi61
#5prighi61 Member Posts: 41  
posted: 10/29/2021 7:48:43 AM(UTC)
Hi vinci, are you aware that you cannot execute an application that require a Windows user interface in a "batch" remote environment?

Active Discussions

Lansweeper Linux Agent - login user
by  Dinusha Chandrasinghe   Go to last post Go to first unread
Last post: Today at 11:03:07 AM(UTC)
Lansweeper device with multiple NICs
by  mzipperer  
Go to last post Go to first unread
Last post: Yesterday at 7:42:57 PM(UTC)
Lansweeper Internal Note
by  mdavis2503   Go to last post Go to first unread
Last post: Yesterday at 6:00:07 PM(UTC)
Lansweeper Problem with deploy software
by  Max90  
Go to last post Go to first unread
Last post: Yesterday at 12:09:40 PM(UTC)
Lansweeper Can lsagent be protected from deletion
by  RKCar   Go to last post Go to first unread
Last post: 11/29/2021 8:56:09 PM(UTC)
Lansweeper HTTPS not secure
by  Larry Rhea  
Go to last post Go to first unread
Last post: 11/29/2021 7:50:59 PM(UTC)
Lansweeper Warning about Built-in Admin
by  Larry Rhea   Go to last post Go to first unread
Last post: 11/29/2021 7:45:45 PM(UTC)