Notification

Icon
Error

Office 365 v2 Scanning Error - Microsoft Cloud Service Modern Authentication Scanning Error

Posted: Friday, April 16, 2021 7:37:57 PM(UTC)
DJX

DJX

Member Original PosterPosts: 3
1
Like
I am trying to setup Lansweeper to scan my Office 365 environment using modern authentication but the scanning targets page is showing "Sequence contains no elements". Basic authentication scanning using the legacy "Office 365" credential is working fine. I followed these three KBs: https://www.lansweeper.c...d-services-application/, https://www.lansweeper.c...rosoft-cloud-credential/ and https://www.lansweeper.c...osoft-cloud-credential/. I tried with a client secret and with a certificate thumbprint. Result is the same with either. Any thoughts?
MarkPinnacle
#1MarkPinnacle Member Posts: 1  
posted: 4/20/2021 11:02:23 AM(UTC)
Hi. Did you follow this article as well and add the permissions?
https://www.lansweeper.c...rosoft-cloud-credential/

When you say you tried a certificate thumbprint as well, how did you generate a certificate? I have it working using a client secret but would like to use a certificate to get the extra mailbox information.
FrankSc
#2FrankSc Member Administration Posts: 134  
posted: 4/20/2021 4:05:50 PM(UTC)
Originally Posted by: DJX Go to Quoted Post
I am trying to setup Lansweeper to scan my Office 365 environment using modern authentication but the scanning targets page is showing "Sequence contains no elements". Basic authentication scanning using the legacy "Office 365" credential is working fine. I followed these three KBs: https://www.lansweeper.c...d-services-application/, https://www.lansweeper.c...rosoft-cloud-credential/ and https://www.lansweeper.c...osoft-cloud-credential/. I tried with a client secret and with a certificate thumbprint. Result is the same with either. Any thoughts?


Hi, Could you please send an email to support@lansweeper.com with the error you are seeing? We'd like to take a closer look at that.
DJX
#3DJX Member Original PosterPosts: 3  
posted: 4/20/2021 6:20:37 PM(UTC)
Originally Posted by: MarkPinnacle Go to Quoted Post
Hi. Did you follow this article as well and add the permissions?
https://www.lansweeper.c...rosoft-cloud-credential/

When you say you tried a certificate thumbprint as well, how did you generate a certificate? I have it working using a client secret but would like to use a certificate to get the extra mailbox information.


I did:
UserPostedImage


As far as the certificate goes, I have a wildcard cert for my domain.
I just uploaded the cert to the Azure portal and since I'm already using the same cert on the Lansweeper web server I should be go to go.

DJX
#4DJX Member Original PosterPosts: 3  
posted: 4/20/2021 6:23:38 PM(UTC)
This is the specific error I'm getting:
UserPostedImage
maciej.przygodzki
#5maciej.przygodzki Member Posts: 10  
posted: 4/30/2021 11:59:43 AM(UTC)
We also have the same problem. I did the configuration step by step using Your manuals from the websites:

https://www.lansweeper.c...rosoft-cloud-credential/
https://www.lansweeper.c...NTAwJmFzc2V0Y291bnQ9MTA2


Unfortunately it receives an error when trying to scan: Sequence contains no elements

What I need to do, to resolve this issue ?

My Lansweeper version is: 8.3.100.23
GregS
#6GregS Member Posts: 1  
posted: 5/1/2021 1:25:49 AM(UTC)
Originally Posted by: maciej.przygodzki Go to Quoted Post
We also have the same problem. I did the configuration step by step using Your manuals from the websites:

https://www.lansweeper.c...rosoft-cloud-credential/
https://www.lansweeper.c...NTAwJmFzc2V0Y291bnQ9MTA2


Unfortunately it receives an error when trying to scan: Sequence contains no elements

What I need to do, to resolve this issue ?

My Lansweeper version is: 8.3.100.23



Same issue here
FrankSc
#7FrankSc Member Administration Posts: 134  
posted: 5/4/2021 12:30:16 PM(UTC)
Hello,
We recommend sending a mail to support@lansweeper.com for scanning errors like these. In this way, these errors get prioritized accordingly to get them fixed as soon as possible.

Active Discussions

Lansweeper Modifying Purchase Date / Yearly Refresh Report
by  Cripple.Zero  
Go to last post Go to first unread
Last post: 5/7/2021 7:06:47 PM(UTC)
Lansweeper Report showing only Wi-Fi Devices and MAC addresses
by  ethanthekiwi   Go to last post Go to first unread
Last post: 5/6/2021 9:18:07 PM(UTC)
Lansweeper Tweak LanSweepers Bios Version Audit to show Last Seen
by  Tyler M.  
Go to last post Go to first unread
Last post: 5/6/2021 8:22:40 PM(UTC)
Lansweeper Patch Volume Across Fleet
by  darren.kimber  
Go to last post Go to first unread
Last post: 5/5/2021 11:29:33 PM(UTC)
Lansweeper Show Date Without Time
by  nhouse24   Go to last post Go to first unread
Last post: 5/4/2021 10:39:43 PM(UTC)
Lansweeper Report of list of assets
by  Carlos Montes  
Go to last post Go to first unread
Last post: 5/4/2021 2:52:15 PM(UTC)