Notification

Icon
Error

Lansweeper Not Opening After Update - Stuck At Updating 1-235

Posted: Monday, September 14, 2020 6:52:38 PM(UTC)
Terry1337

Terry1337

Member Original PosterPosts: 17
1
Like
Hello,

I have been contacting support and did not receive a solution to my updates not completing after the recent upgrade to newest Lansweeper. The only suggestion I received and got to work is uninstalling Lansweeper and Installing a new Lansweeper. I now have an SQL Express install. I saved a copy of my old Lansweeper in a Lansweeper old folder. How do I get the .mdf database into the new SQL database?

Thanks,
Terry
FrankSc
#1FrankSc Member Administration Posts: 87  
posted: 9/15/2020 2:17:44 PM(UTC)
Hi,

If you have an .mdf, you can stop the Lansweeper LocalDB service under Windows Services and then put that file in C:\Program Files (x86)\Lansweeper\SQLData. Then start the service again, this should bring your environment up again.

Terry1337
#2Terry1337 Member Original PosterPosts: 17  
posted: 9/15/2020 2:49:36 PM(UTC)
I only have the Lansweeper Server service. Will that work instead of Lansweeper LocalDB?
Terry1337
#3Terry1337 Member Original PosterPosts: 17  
posted: 9/15/2020 6:59:09 PM(UTC)
I uninstalled the SQL version and did an easy install. When I try to start the program through the web interface I get the updating error again. Sticks on updating 1-245.

Frustrated!!!!!
Terry
jshulenberger
#4jshulenberger Member Posts: 2  
posted: 9/16/2020 6:39:52 PM(UTC)
I had the same issues. It treated me as a new install. Contacting support went nowhere. I was able to go in to the "Lansweeper Config Editor" ("C:\Program Files (x86)\Lansweeper\Tools\ConfigEditor.exe") and change the database server to my SQL instance (on both the Service, and Website tabs), and everything came right up for me.
Terry1337
#5Terry1337 Member Original PosterPosts: 17  
posted: 9/16/2020 6:57:05 PM(UTC)
Originally Posted by: jshulenberger Go to Quoted Post
I had the same issues. It treated me as a new install. Contacting support went nowhere. I was able to go in to the "Lansweeper Config Editor" ("C:\Program Files (x86)\Lansweeper\Tools\ConfigEditor.exe") and change the database server to my SQL instance (on both the Service, and Website tabs), and everything came right up for me.


I looked in the Configeditor and have the setting Localdb\. \LSInstance in both Services & Website. Which install did you do? When I open the ConfigEditor I receive an error not connecting to the database.

I have been using the free version for years. This is the first time I had issues when doing an update to the program. I have tried several times to uninstall and install a clean version but every time I keep getting the Scripting error.
JSchlackman
#6JSchlackman Member Posts: 15  
posted: 9/22/2020 3:57:30 PM(UTC)
I'm afraid I don't have any insight regarding a fix but for what it's worth I had the exact same problem when updating from 8.0.130.23 to 8.0.130.37 on an SQL install.

After about an hour of fiddling I just restored my server from backup as I couldn't afford the downtime for troubleshooting. I'll be sitting out this version.
Terry1337
#7Terry1337 Member Original PosterPosts: 17  
posted: 9/22/2020 7:36:40 PM(UTC)
I uninstalled Lansweeper then installed version 6 and restored a copy. I then updated to 7.2.108.6. I can now logon on and use the program. I can also go into Tools and Database Maintenance and see the (localdb)\.\LSInstance\lansweeperdb and have a health status. When I try to open Microsoft SQL Management Studio using server name as: (localdb)\.\LSInstance and SQL Server Authentication and my logon to Lansweeper I receive the error:TITLE: Connect to Server


Cannot connect to (localdb)\.\LSInstance.


ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 50 - Local Database Runtime error occurred. The specified LocalDB instance does not exist.
) (Microsoft SQL Server, Error: -1983577849)

For help, click: http://go.microsoft.com/...577849&LinkId=20476


BUTTONS:

OK



I checked my services and they are all set to automatic.

Any suggestions?

Thanks,
Terry
Terry1337
#8Terry1337 Member Original PosterPosts: 17  
posted: 9/23/2020 3:09:42 PM(UTC)
Tried to open Lansweeper today and am receiving the error: Update in process. processing script-1 of 214. Any suggestions appreciated!
FrankSc
#9FrankSc Member Administration Posts: 87  
posted: 9/23/2020 3:40:51 PM(UTC)
This message normally shows up if the service is not able to find the database. This normally indicates that the Lansweeper LocalDB service is not started or cannot be found.
You should have a file called Lansweeper.LocalDB.Service.txt normally in C:\Program Files (x86)\Lansweeper\Service. This could contain more info on why the service files to start.

If any doubt, better send it to support@lansweeper.com for further troubleshooting.
Terry1337
#10Terry1337 Member Original PosterPosts: 17  
posted: 9/23/2020 4:48:26 PM(UTC)
I restarted both of the Lansweeper and IIS services. I was then able to open Lansweeper. I then went to SSMS and was able to logon with windows authentication and do a backup of my Lansweeper. Next will try to update to a more current version but at least I have a backup now.

Active Discussions

Report Center Default Browser and Version
by  RC62N   Go to last post Go to first unread
Last post: Yesterday at 8:00:54 PM(UTC)
Lansweeper Trying to make a custom report that sorts assets by state
by  mzipperer  
Go to last post Go to first unread
Last post: 11/25/2020 5:36:52 PM(UTC)
Lansweeper Report - All Assets with Specfic Default Gateway
by  RC62N   Go to last post Go to first unread
Last post: 11/25/2020 4:18:08 PM(UTC)
Report Center Windows update report
by  ToeJoe  
Go to last post Go to first unread
Last post: 11/24/2020 3:39:00 PM(UTC)
Lansweeper Report - assets
by  Andy.S   Go to last post Go to first unread
Last post: 11/23/2020 2:42:01 PM(UTC)
Lansweeper Run Report on PCs from a list
by  RC62N  
Go to last post Go to first unread
Last post: 11/16/2020 4:23:12 PM(UTC)