Notification

Icon
Error

Report on Specific list of Workstations - Report generated from list

Posted: Thursday, September 17, 2020 6:44:48 PM(UTC)
mmeetze

mmeetze

Member Original PosterPosts: 23
0
Like
I have a list that we pulled out of azure with hostnames, and I have created a comma separated list in hopes of being able to plug this list into a query here and generate the data needed. For us we are only wanting to capture the Model/OS/OS Version/LastSeen/LastScanned/AD Location for computer object.
Brandon
#1Brandon Member Posts: 57  
posted: 9/17/2020 9:13:54 PM(UTC)
Is this for all the computers in your network, or just certain ones? If it is only certain computers how did you decide which computers? Depending on what you used as your criteria, Lansweeper may be able to select just those computers and give you the information you need in a report.
mmeetze
#2mmeetze Member Original PosterPosts: 23  
posted: 9/17/2020 9:19:34 PM(UTC)
My first thought was just to leverage Lansweeper as well but this list was not derived from Lansweeper so there wasnt any queries setup. We are onboarding all machines into Azure and we have identified the machines and exported a list who are currently experiencing issues. So we need to gather the Models/OS Version and such as to begin the investigation as to why this is not successfully joining. Also this is not a small list, we have over 2K workstations that will need to be included in this particular report.
Brandon
#3Brandon Member Posts: 57  
posted: 9/17/2020 9:29:23 PM(UTC)
The only thing that I can think of is in the report do a where assetname like and enter the computer names there. Just make sure there is an or statement between each where statement.
mmeetze
#4mmeetze Member Original PosterPosts: 23  
posted: 9/18/2020 3:46:55 PM(UTC)
I am having some issues getting this to work properly and would love some advice. Here is my query

Select Top 1000000 tblAssets.AssetID,
tblAssets.AssetName,
tsysAssetTypes.AssetTypename,
tsysAssetTypes.AssetTypeIcon10 As icon,
tblAssets.IPAddress,
tblAssets.Lastseen,
tblAssets.Lasttried,
tblADComputers.Location,
tblAssets.OScode
From tblAssets
Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
Inner Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
Inner Join tblADComputers On tblAssets.AssetID = tblADComputers.AssetID
Where
tblAssets.AssetName =
'is like XXXXX,OR XXXXXX,OR XXXXXX,OR XXXXXXX,OR XXXXXXXX,OR XXXXXXX,OR XXXXXXXX,OR XXXXXX,OR mac0182273,OR XXXXXX'
And tblAssetCustom.State = 1


Now I have masked the hostnames above and shortened the list considerably, but is this the correct format that I am using? When I run it I get no results

Brick wall
RC62N
#5RC62N Member Posts: 488  
posted: 9/18/2020 4:24:25 PM(UTC)
IN (list) works if you've got a list of possible values to compare against.
Code:
WHERE
  tblAssetCustom.State = 1
  AND tblAssets.AssetName IN ('AAA', 'BBB', 'CCC', 'DDD', 'EEE')
It's a shorthand version of
Code:
  tblAssetCustom.State = 1
  AND (tblAssets.AssetName = 'AAA'
       OR tblAssets.AssetName = 'BBB'
       OR tblAssets.AssetName = 'CCC'
       OR tblAssets.AssetName = 'DDD'
       OR tblAssets.AssetName = 'EEE')
Brandon
#6Brandon Member Posts: 57  
posted: 9/18/2020 4:50:15 PM(UTC)
Where would you put the path to the list? Would a csv file work?
RC62N
#7RC62N Member Posts: 488  
posted: 9/18/2020 5:00:11 PM(UTC)
The "report" (query) is self-contained. You would need to open your CSV list in a text editor
Code:
AAA,BBB,CCC,DDD,EEE

reformat it to put single-quotes around the machine names
Code:
'AAA','BBB','CCC','DDD','EEE'

and copy/paste that between the parentheses in the query
Code:
WHERE
  tblAssetCustom.State = 1
  AND tblAssets.AssetName IN ('AAA','BBB','CCC','DDD','EEE')

Active Discussions

Lansweeper Lansweeper Errors - Licencing and scanning
by  dnkleaf   Go to last post Go to first unread
Last post: Yesterday at 1:02:13 PM(UTC)
Lansweeper Search for Blank Fields
by  CS Caritas Socialis IT  
Go to last post Go to first unread
Last post: Yesterday at 12:19:05 PM(UTC)
Lansweeper Uninstalled software still listed
by  Dennis Gewillig   Go to last post Go to first unread
Last post: Yesterday at 9:19:19 AM(UTC)
Lansweeper Software deployment initiated by user
by  LS_enthusiast_4444   Go to last post Go to first unread
Last post: 11/26/2020 9:28:18 PM(UTC)
Lansweeper Help Desk not disabling for regular users?
by  FrankSc  
Go to last post Go to first unread
Last post: 11/26/2020 8:18:38 PM(UTC)
Lansweeper Satisfaction Questionnaire after ticket close
by  mouaad   Go to last post Go to first unread
Last post: 11/26/2020 4:31:44 PM(UTC)
Lansweeper Microsoft EDGE browser support
by  Vapoured  
Go to last post Go to first unread
Last post: 11/26/2020 4:54:30 AM(UTC)