Notification

Icon
Error

Windows Update Setting Report

Posted: Tuesday, August 11, 2020 5:11:45 PM(UTC)
Brandon

Brandon

Member Original PosterPosts: 43
1
Like
This issue has been solved! Click here to view the solution
The windows update settings built report is only listing 182 out of 800 computers. I copied the report from the built in reports forum and pasted it into my report and to see if maybe it has been edited, but I still only get 182 computers listed. Any ideas>
Denis Sauneuf
#1Denis Sauneuf Member Posts: 1  
posted: 8/21/2020 7:36:52 AM(UTC)
There is a mistake in the code of this report.

You may create a new one with the code below:
(Menu report > create new report
Paste this code in the bottom area, and save and run.)

Select Top 1000000 tblAssets.AssetID,
tblAssets.AssetName,
tblState.Statename,
tblAssets.Description,
tblAssets.Domain,
tblAssets.Username,
tblAssets.Userdomain,
Coalesce(tsysOS.Image, tsysAssetTypes.AssetTypeIcon10) As icon,
tblAssets.IPAddress,
tsysIPLocations.IPLocation,
tblAssetCustom.Manufacturer,
tblAssetCustom.Model,
tsysOS.OSname As OS,
tsysOS.OScode As Build,
tblAssets.SP,
tblAssets.Version,
tblAssets.Lastseen,
tblAssets.Lasttried,
Case tblRegistry.Value
When '5' Then
'Automatic Updates is required, but end users can configure it'
When '4' Then 'Automatic download and scheduled installation'
When '3' Then 'Automatic download and notify of installation'
When '2' Then 'Notify before download'
When '1' Then 'Never check for updates'
Else 'Unknown, try rescanning the machine'
End As UpdateSettings
From tblAssets
Left Join tsysOS On tsysOS.OScode = tblAssets.OScode
Inner Join tblAssetCustom On tblAssetCustom.AssetID = tblAssets.AssetID
Left Join tsysAssetTypes On tsysAssetTypes.AssetType = tblAssets.Assettype
Left Join tsysIPLocations On tsysIPLocations.LocationID = tblAssets.LocationID
Inner Join tblState On tblState.State = tblAssetCustom.State
Left Join tblRegistry On tblRegistry.AssetID = tblAssets.AssetID and tblRegistry.Valuename = 'auoptions'
Where -- tblState.Statename = 'Active' And
tsysAssetTypes.AssetTypename In ('Windows', 'Windows CE')
Order By tblAssets.Domain,
tblAssets.AssetName


Brandon
#2Brandon Member Original PosterPosts: 43  
posted: 8/21/2020 1:17:34 PM(UTC)
Thanks! That fixed it!

Active Discussions

Lansweeper Show attached USB devices
by  Dannnnooo   Go to last post Go to first unread
Last post: Today at 10:42:17 AM(UTC)
Lansweeper Lansweeper Ubiquiti AP Bullet Devices
by  Beta_Tester  
Go to last post Go to first unread
Last post: Today at 8:59:06 AM(UTC)
Lansweeper Report to find ScanServer 'not working'
by  Rocher Vincent   Go to last post Go to first unread
Last post: Today at 8:07:26 AM(UTC)
Lansweeper Security: HSTS Missing
by  Grey  
Go to last post Go to first unread
Last post: Yesterday at 9:36:49 PM(UTC)
Lansweeper Include custom ticket fields as email tags
by  brownscar   Go to last post Go to first unread
Last post: 9/29/2020 4:09:02 PM(UTC)
Lansweeper SSH - Keyboard Interactive Authentication
by  blackmoonwolf  
Go to last post Go to first unread
Last post: 9/29/2020 1:21:59 PM(UTC)
Lansweeper Lansweeper Dark Theme
by  blackmoonwolf   Go to last post Go to first unread
Last post: 9/29/2020 1:18:32 PM(UTC)
Lansweeper Drag and Drop Email
by  Chris Durham  
Go to last post Go to first unread
Last post: 9/29/2020 7:13:09 AM(UTC)