Notification

Icon
Error

SMBv1 disabled - Report about SMBv1 active or not

Posted: Monday, January 8, 2018 1:22:55 PM(UTC)
stiwa

stiwa

Member Original PosterPosts: 64
0
Like
This issue has been solved! Click here to view the solution
Hi,
is it possible to create a report whether the SMBv1 feature is installed or not on Windows 2012 R2 an up servers?
Esben.D
#1Esben.D Member Administration Posts: 1,982  
posted: 1/8/2018 1:54:33 PM(UTC)
You can use this built-in report "Windows: Installed Windows features" and add the following criteria:
  • For tsysOS.OSname: LIKE 'Win 20%'
  • For tblFeatureUni.featureName: LIKE 'SMB%'
You can find a copy of the built-in report here: https://m.lansweeper.com...-Built-in.aspx#post51421

For detecting if SMB is active or not I found some relevant info here: https://www.reddit.com/r...jc67fad9&sh=3ad3bde2

It states that the registry key HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters has a value called SMB1 which, if enabled is set to 1, if disabled is set to 0.

You add that registry value for scanning and use this sample report to report on it: https://www.lansweeper.c...-scanning.aspx#post39295
joe_user
#2joe_user Member Posts: 14  
posted: 2/12/2020 9:46:59 PM(UTC)
If a features is "installed," does that mean its active?

Active Discussions

Lansweeper Understanding current setup
by  ggarcia   Go to last post Go to first unread
Last post: Today at 12:24:42 AM(UTC)
Lansweeper Remote desktop custom port
by  sefaucher  
Go to last post Go to first unread
Last post: Yesterday at 10:30:49 PM(UTC)
Lansweeper Unable to transfer user's data prior to removal
by  RickW99456   Go to last post Go to first unread
Last post: Yesterday at 9:06:14 PM(UTC)
Lansweeper Unable to access the lansweeper consol for other computer
by  Kudnan Ingle  
Go to last post Go to first unread
Last post: Yesterday at 7:49:32 PM(UTC)
Lansweeper Closing and re-opening of tickets
by  NWHiker   Go to last post Go to first unread
Last post: Yesterday at 3:42:56 PM(UTC)
Lansweeper Wake on Lan Issues
by  woldummy  
Go to last post Go to first unread
Last post: Yesterday at 3:42:07 PM(UTC)
Lansweeper Deploy and start Software
by  EDV_OHZ   Go to last post Go to first unread
Last post: Yesterday at 12:49:08 PM(UTC)
Lansweeper Helpdek Call Re-Opened
by  mouaad  
Go to last post Go to first unread
Last post: Yesterday at 7:30:59 AM(UTC)