HP Warranty scan - broken for some products

Posted: Thursday, November 21, 2019 11:12:40 AM(UTC)


Member Original PosterPosts: 9
Hello Folks,

Looks like scanning HP warranty on some devices is broken when we're scanning against the HPE database.
See this:

Parsing error: Cannot parse ''

If I manually copy the URL above and end up at the HPE site it states that:

"The information you provided does not match our records. Please review your entry again and make any necessary edits or contact HPE for more assistance."

If one uses the HP warranty check site (not HPE):

Its happy and doesn't produce any error, just provides the correct warranty details.

Is there a way to add an alternative warranty check URL to lansweeper?

#1Esben.D Member Administration Posts: 1,977  
posted: 11/22/2019 2:59:06 PM(UTC)
Are you sure you are on the latest version?

We regularly update HP warranty retrieval since HP likes to do the same ;)
#2Moopere Member Original PosterPosts: 9  
posted: 11/23/2019 8:34:11 AM(UTC)

Checking for updates tells me that I'm up to date.
M Redfern
#3M Redfern Member Posts: 1  
posted: 12/10/2019 12:30:44 PM(UTC)
We have exactly the same issue, there have been no successful HP warranty scans for us since 24/10/19, 2 days after the last Lansweeper release came out
#4DJohnson Member Posts: 1  
posted: 12/11/2019 12:14:16 AM(UTC)
Just put up a new Lansweeper installation yesterday and I am having the same issue. I installed the update that was released today and am still getting the parsing error.
#5Cweeks Member Posts: 1  
posted: 12/11/2019 2:10:49 AM(UTC)
Week old install for me. No warranty info. Last version worked fine
#6Esben.D Member Administration Posts: 1,977  
posted: 12/12/2019 3:17:05 PM(UTC)
I've checked further and there is a known issue with retrieving warranty data from HP devices. The HP API has been down for a while and our fallback method of scraping the website, unfortunately, is non-functional currently as well due to changes at the end of HP. We're currently in contact with HP to try to get a more permanent resolution here, to hopefully set up reliable warranty retrieval via API (as we do for Dell).

Unfortunately, as we're reliant on a 3rd party, slowing down the process, it's difficult to give an estimate on when we can resolve this.
#7Moopere Member Original PosterPosts: 9  
posted: 1/3/2020 8:39:30 AM(UTC)
This problem appears to be fixed now? Can anyone confirm?

The warranty scan errors in the lansweeper log are gone and the problematic printers seem to have updated details.
#8nnewton Member Posts: 15  
posted: 1/8/2020 2:37:11 AM(UTC)
I'm on v7.2.105.2 and I have 139 warranty scanning errors in the report, all of them are HP.

Most of them are this error:

Parsing error: Cannot parse '<SERIAL>'

I tried one of the URLs in a browser and it returned a warranty page, but after refreshing a few warranties, I started getting this:

Could not open page
The service or information you requested is not available at this time.
Please try again later.

(Error: system-websrv_unavail)

I guess HP have a very strict limit for warranty queries.
Jack of All Trades
#9Jack of All Trades Member Posts: 6  
posted: 1/9/2020 11:26:00 AM(UTC)
Not fixed. Im on the latest version - and still can't see warranty for our HP products...
#10TBMPS Member Posts: 1  
posted: 1/21/2020 3:29:08 AM(UTC)
The use of the HP warranty scan is the primary purpose for my wanting to use Lansweeper. Seemed to have a good following too. Any word on when this might be working again? I am currently running in trial mode, if we can get this feature working, I will definitely be a paid user.
#11nnewton Member Posts: 15  
posted: 1/21/2020 4:11:59 AM(UTC)
The warranty scanning used to be really good a few years ago, but I think HP started really restricting it. Seems like you can only look up a couple at a time before it starts blocking you.

I've registered for the HP Developers so I can access the warranty using the API, but that doesn't work for servers since the split and now we get this on the warranty API page at HP:

Please note: The beta Warranty API is currently unavailable.
We will resume operations at a later time.
For small numbers of devices, please consider HP Support's manual Warranty Checking web form.

So all-around terrible when looking up HP warranties.

None of this is really LANSweeper's fault, I think they are doing the best they can with what HP is providing.

Luckily we only use HP for our ESX host blades, so manually looking up and populating the warranty dates for 10-20 new machines every year isn't too onerous.
#12zaty Member Posts: 1  
posted: 2/21/2020 1:52:38 PM(UTC)
i wrote for myself Powershell script to get all HP computers/laptop assets from DB, use Powershell module to get warranty info thru SOAP API and update asset in DB.

You will need these PS1 modules:


$assets = Invoke-Sqlcmd -ServerInstance servername -Database lansweeperdb -Username lansweeperuser -Password 'password' -Query @"
SELECT a.AssetID, a.AssetName, b.Serialnumber, b.SystemSKU
FROM lansweeperdb.dbo.tblAssets a, lansweeperdb.dbo.tblAssetCustom b
WHERE a.AssetID = b.AssetID AND
a.Assettype = -1 AND
b.Warrantydate is NULL AND
b.Manufacturer in ('HP','Hewlett-Packard');

foreach ($asset in $assets) {
    $assetId = $asset.AssetID
    $assetName = $asset.AssetName

    $warranty = ((Get-HPIncWarrantyEntitlement -SerialNumber $asset.SerialNumber -ProductNumber $asset.SystemSKU).OverallEntitlementEndDate | Measure-Object -Maximum).Maximum
    Write-Output "$assetID  $assetName  $warranty"

    Invoke-Sqlcmd -ServerInstance servername -Database lansweeperdb -Username lansweeperuser -Password 'password' -Query @"
    UPDATE dbo.tblAssetCustom
    SET Warrantydate = '$warranty'
    WHERE assetID = $assetId

Active Discussions

Lansweeper Changes in the licensing model
by  BullGates   Go to last post Go to first unread
Last post: Today at 7:30:32 PM(UTC)
Lansweeper About Memory Changes
by  fjca  
Go to last post Go to first unread
Last post: Today at 5:51:17 PM(UTC)
Lansweeper Wildcard in file scanning to get all files in a directory?
by  RKCar   Go to last post Go to first unread
Last post: Today at 4:03:43 PM(UTC)
Lansweeper Wishlist is dead, no responses from LS staff.
by  RobertB  
Go to last post Go to first unread
Last post: Today at 3:08:12 PM(UTC)
Lansweeper Deploy installer packages not working any more
by  richv   Go to last post Go to first unread
Last post: Today at 3:06:19 PM(UTC)
Lansweeper File Scanning
by  RKCar  
Go to last post Go to first unread
Last post: Today at 2:22:54 PM(UTC)
Lansweeper HP Warranty scan - broken for some products
by  zaty   Go to last post Go to first unread
Last post: Today at 1:52:38 PM(UTC)
Lansweeper How to stop deployments ?
by  Leandro Martins  
Go to last post Go to first unread
Last post: Today at 1:47:22 PM(UTC)