Notification

Icon
Error

Hyper-V guests dissapeared and reappeared

Posted: Thursday, November 14, 2019 3:00:58 PM(UTC)
Cm.Cody

Cm.Cody

Member Original PosterPosts: 4
0
Like
Greetings

I was wondering about few things bout Lansweeper.

We have a Hyper-V cluster at work and I'd like to know how does Lansweeper relate hyper-v guests to host ? What protocol or tool he uses to detect it ?
And how does he know which machine is physical and which is virtual, becouse during scanning ip range it discovered machines and some of them were discovered as Windows and some as Linux. I changed asset type of these Linux machines as Hyper-V guests, but still I don't understand how does lansweeper relate them to the host. Now I got 2 asset types in my cluster
1) Windows
2) Hyper-V guest

I know I can't change Windows asset type to Hyper-V guest, unless I remove it and add manually again, but won't it change it back to Windows asset type ?

Secondly I've noticed that on some nodes of the cluster it shows related machines, but on some nodes those machines dissapeared yesterday, and reappeared today. What may be couse of such thing ? After they disappeared I rescaned host few times, and also today in the morning, but without luck. During the day, they just got back again to the host.

Sorry for chaotic question and not very good english.

Regards,

Cm.Cody
Esben.D
#1Esben.D Member Administration Posts: 1,956  
posted: 11/18/2019 4:30:47 PM(UTC)
Hi Cody

It is important to understand that a Hyper-V guest asset is only something used within Lansweeper if the asset has not been scanned directly, and therefore has only been scanned through the Host.
Once Lansweeper gathers more data by scanning an asset directly, it changes the type to the more detailed asset type.

On the asset page and host page, you will still see all the links as to who is the host/guest machines, and you can use reports for an overview too.

As for hyper-v guest assets, I believe this data is just scanned from the host's WMI classes. Cluster and Hyper-V logs are retrieved using PowerShell.

Maybe the PS script fails at times? Check if you meet all the requirements: https://www.lansweeper.c...luster-details-and-logs/
Cm.Cody
#2Cm.Cody Member Original PosterPosts: 4  
posted: 11/19/2019 11:10:35 AM(UTC)
Hi Esben.D

Thank you for your response. It is very helpfull since I am new to lansweeper. I was also wondering, becouse at some hyper-v guests I got error "RPC unavailable" I was searching through lansweeper page and forum and only found: "RPC server unavailable" Are those 2 the same errors ?
Is this error caused by lack of some permissions to scan asset or is it something else ?

Regards,

Cody

Active Discussions

Lansweeper iManage Client deployment
by  CyberCitizen   Go to last post Go to first unread
Last post: Today at 3:09:47 AM(UTC)
Lansweeper Missing hyperv host details for guest asset LAN-4130
by  danielm  
Go to last post Go to first unread
Last post: 12/7/2019 7:15:56 AM(UTC)
Lansweeper Lansweeper showing MAC address instead of name
by  crashff   Go to last post Go to first unread
Last post: 12/6/2019 10:26:25 PM(UTC)
Lansweeper Dell Warranty Lookup - Incorrect Information
by  Trenton Knew  
Go to last post Go to first unread
Last post: 12/6/2019 10:17:15 PM(UTC)
Lansweeper Incoming Email Parse
by  UEFT   Go to last post Go to first unread
Last post: 12/6/2019 5:46:22 PM(UTC)
Lansweeper SSH - Keyboard Interactive Authentication
by  KevinA-REJIS  
Go to last post Go to first unread
Last post: 12/6/2019 5:22:21 PM(UTC)
Lansweeper Custom OID Scanning / multible OIDs with wildcards
by  Esben.D  
Go to last post Go to first unread
Last post: 12/6/2019 11:57:18 AM(UTC)