Notification

Icon
Error

lsagent not scanning/sending when using relay

Posted: Thursday, March 7, 2019 4:27:10 PM(UTC)
Hatchoroo

Hatchoroo

Member Original PosterPosts: 2
1
Like
Hello,

we're having trouble in letting lsagent scan and send results to relay.lansweeper.com on our test laptops.
They send the results without any issues to our internal lansweeper server.

From lsagentlog.txt I would think that the schedule to start the scan after detecting that relay.lansweeper.com needs to be used never happens.

Our 3 test laptops are Windows 7 64bit and have .NET 4.7.2 installed. One of the 3 laptops has been generating these kind of logs while having complete internet access for 3 days now.

Does anyone have any idea what could be wrong?

2019-03-07 15:10:09,320 [1] INFO Starting Lansweeper Agent Service
2019-03-07 15:10:09,570 [6] INFO === Service started ===
2019-03-07 15:10:14,171 [7] DEBUG Detected OS: Windows
2019-03-07 15:10:14,186 [7] DEBUG Client Version: 7.0.110.2
2019-03-07 15:10:14,186 [7] DEBUG Reading ini file...
2019-03-07 15:10:15,231 [7] DEBUG Created InternalCommunicationSender to URL https://DUMMY:9524/lsagent
2019-03-07 15:10:15,247 [7] DEBUG New AssetId created: DUMMY.
2019-03-07 15:10:15,450 [7] DEBUG Asset is enabled.
2019-03-07 15:10:15,450 [7] DEBUG Retrieving configuration...
2019-03-07 15:10:15,715 [7] DEBUG Updating local config
2019-03-07 15:10:16,042 [7] DEBUG Checking version.
2019-03-07 15:10:16,042 [7] DEBUG Waiting for schedule...
2019-03-07 15:10:16,042 [7] DEBUG Schedule triggered
2019-03-07 15:10:16,042 [7] DEBUG Starting scan
2019-03-07 15:10:16,042 [7] DEBUG Detected OS: Windows
2019-03-07 15:10:30,359 [7] DEBUG Scanning computer...
2019-03-07 15:12:13,546 [7] DEBUG Computerscan completed.
2019-03-07 15:12:13,546 [7] DEBUG Compressing scanfile.
2019-03-07 15:12:13,889 [7] DEBUG Scan has been sent.
2019-03-07 15:15:36,567 [1] INFO Starting Lansweeper Agent Service
2019-03-07 15:15:36,833 [6] INFO === Service started ===
2019-03-07 15:15:51,341 [7] DEBUG Detected OS: Windows
2019-03-07 15:15:51,356 [7] DEBUG Client Version: 7.0.110.2
2019-03-07 15:15:51,356 [7] DEBUG Reading ini file...
2019-03-07 15:15:52,323 [7] INFO CreateReachableEndPoint for DUMMY
2019-03-07 15:15:55,787 [7] INFO Url Check with address failed. Endpoint with address 'https://DUMMY:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY'
2019-03-07 15:15:55,787 [7] WARN Connection to url https://DUMMY:9524/lsagent failed
2019-03-07 15:15:55,911 [7] INFO Url Check with address failed. Endpoint with address 'https://DUMMY.testdomain.com:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY.testdomain.com'
2019-03-07 15:15:55,911 [7] WARN Connection to url https://DUMMY.testdomain.com:9524/lsagent failed
2019-03-07 15:15:58,205 [7] INFO Url Check with address failed. Endpoint with address 'http://DUMMY:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY'
2019-03-07 15:15:58,205 [7] WARN Connection to url http://DUMMY:9524/lsagent failed
2019-03-07 15:15:58,314 [7] INFO Url Check with address failed. Endpoint with address 'http://DUMMY.testdomain.com:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY.testdomain.com'
2019-03-07 15:15:58,314 [7] WARN Connection to url http://DUMMY.testdomain.com:9524/lsagent failed
2019-03-07 15:15:58,314 [7] DEBUG Created RelayCommunicationSender to URL https://relay.lansweeper.com/EchoService.svc
2019-03-07 15:15:58,407 [7] DEBUG Attach ServerCertificateValidationCallback
2019-03-07 15:15:58,563 [7] DEBUG CreateFactoryInstance for endpoint https://relay.lansweeper.com/EchoService.svc, EchoService
2019-03-07 15:16:00,326 [7] DEBUG ServicePointManager.ServerCertificateValidationCallback
2019-03-07 15:16:01,153 [7] DEBUG Asset is enabled.
2019-03-07 15:16:01,153 [7] DEBUG Retrieving configuration...
2019-03-07 15:16:01,933 [7] DEBUG Updating local config
2019-03-07 15:16:01,933 [7] DEBUG Checking version.
2019-03-07 15:16:01,933 [7] DEBUG Waiting for schedule...
2019-03-07 15:31:02,113 [7] INFO CreateReachableEndPoint for DUMMY
2019-03-07 15:31:05,155 [7] INFO Url Check with address failed. Endpoint with address 'https://DUMMY:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY'
2019-03-07 15:31:05,155 [7] WARN Connection to url https://DUMMY:9524/lsagent failed
2019-03-07 15:31:05,311 [7] INFO Url Check with address failed. Endpoint with address 'https://DUMMY.testdomain.com:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY.testdomain.com'
2019-03-07 15:31:05,311 [7] WARN Connection to url https://DUMMY.testdomain.com:9524/lsagent failed
2019-03-07 15:31:07,619 [7] INFO Url Check with address failed. Endpoint with address 'http://DUMMY:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY'
2019-03-07 15:31:07,619 [7] WARN Connection to url http://DUMMY:9524/lsagent failed
2019-03-07 15:31:07,619 [7] INFO Url Check with address failed. Endpoint with address 'http://DUMMY.testdomain.com:9524/lsagent' was not reachable: De externe naam kan niet worden omgezet: 'DUMMY.testdomain.com'
2019-03-07 15:31:07,619 [7] WARN Connection to url http://DUMMY.testdomain.com:9524/lsagent failed
2019-03-07 15:31:07,619 [7] DEBUG Created RelayCommunicationSender to URL https://relay.lansweeper.com/EchoService.svc
2019-03-07 15:31:08,150 [7] DEBUG ServicePointManager.ServerCertificateValidationCallback
2019-03-07 15:31:08,540 [7] DEBUG Asset is enabled.
2019-03-07 15:31:08,540 [7] DEBUG Retrieving configuration...
2019-03-07 15:31:08,977 [7] DEBUG Updating local config
2019-03-07 15:31:08,992 [7] DEBUG Checking version.
2019-03-07 15:31:08,992 [7] DEBUG Waiting for schedule...




JacobH
#1JacobH Member Posts: 170  
posted: 3/8/2019 6:32:20 AM(UTC)
It looks like the machines cant reach the server.. have you tried pinging the server FQDN from the machine?

You can email support@lansweeper.com for faster support with this issue but I'm glad to help of I can...
Hatchoroo
#2Hatchoroo Member Original PosterPosts: 2  
posted: 3/8/2019 9:43:35 AM(UTC)
Hi JabobH,

you are correct that the machines can't reach the FQDN's of the dummy hostnames (internal lansweeper server), since the dummy hostnames aren't available from outside our corporate network.

As far as I understand, the whole point of lsagent is that it connects and sends the info automatically to relay.lansweeper.com when the internal lansweeper isn't reachable (for example: the machine is connected to a home network).

I'll forward this question to the support and update the topic when I have a working solution.
krejar
#3krejar Member Posts: 67  
posted: 8/9/2019 6:17:18 PM(UTC)
@Hatchoroo My boss and I just had this discussion this morning. Have you heard anything back from support about this?

Originally Posted by: Hatchoroo Go to Quoted Post
Hi JabobH,

you are correct that the machines can't reach the FQDN's of the dummy hostnames (internal lansweeper server), since the dummy hostnames aren't available from outside our corporate network.

As far as I understand, the whole point of lsagent is that it connects and sends the info automatically to relay.lansweeper.com when the internal lansweeper isn't reachable (for example: the machine is connected to a home network).

I'll forward this question to the support and update the topic when I have a working solution.


krejar
#4krejar Member Posts: 67  
posted: 8/9/2019 6:37:36 PM(UTC)
I just did a traffic capture and I see that with a local workstation, or desktop, that it does indeed call out to relay.lansweeper.com. This is concerning us a little bit, but why would a local pc send its LsAgent packet to the cloud then back down to our in-house LS server? Why not just go direct?

I deployed the agent a while ago through the Deployment feature in LS. We're realizing that maybe we should have 2 package deployments. 1 for wireless devices using the relay key and 1 for local hardwired devices using only the FQDN or IP of the LS server. But that seems like added work when you can just have an all in one deployment package.

EDIT:
It does look like all LsAgents call out to the relay.lansweeper.com as the preferred method.
Esben.D
#5Esben.D Member Administration Posts: 1,834  
posted: 8/19/2019 12:31:02 PM(UTC)
Originally Posted by: krejar Go to Quoted Post
It does look like all LsAgents call out to the relay.lansweeper.com as the preferred method.


The cloud relay is only used if either a direct server connection is not configured, or the connection fails. The original log files posted also show this. During the first scan it connects to the server directly, the subsequent scan that connection fails and LsAgents attempts to connect to the relay.

Active Discussions

Lansweeper Remove all users from old domain
by  cmuter   Go to last post Go to first unread
Last post: 9/20/2019 8:03:58 PM(UTC)
Lansweeper Static IP Address
by  cycleheat  
Go to last post Go to first unread
Last post: 9/20/2019 4:07:16 PM(UTC)
Lansweeper Bitlocker Encryption Recovery Key no information found
by  Stephane   Go to last post Go to first unread
Last post: 9/20/2019 2:26:19 PM(UTC)
Lansweeper InTune Scanning Issues
by  Esben.D  
Go to last post Go to first unread
Last post: 9/20/2019 12:34:59 PM(UTC)
Lansweeper Office 365 scanning issues
by  Esben.D   Go to last post Go to first unread
Last post: 9/20/2019 12:23:30 PM(UTC)
Lansweeper Hard Drive Tracking - Start to Finish
by  Lone Jedi  
Go to last post Go to first unread
Last post: 9/19/2019 8:11:56 PM(UTC)
Lansweeper Lansweeper Reporting Old Assets as New
by  Jpatterson   Go to last post Go to first unread
Last post: 9/19/2019 12:52:14 PM(UTC)
Lansweeper Cannot edit a ticket anymore
by  Esben.D  
Go to last post Go to first unread
Last post: 9/19/2019 12:32:42 PM(UTC)