Notification

Icon
Error

dotNET framework 3.5 deployment

Posted: Monday, July 1, 2019 10:33:03 AM(UTC)
TCI

TCI

Member Original PosterPosts: 3
0
Like
On each version update of Windows we face a similar challenge d'oh!
We created a command to install the .NET 3.5 in Windows 10 v 1906.

Quote:
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart


On Windows v1809 this was still working.
However on v1906 the deployment fails due to lack of elevated permissions.
We always install with Scanning Credentials as this account is also local admin on all assets however
it seems DISM requires the NAME administrator for these elevated permissions.
The default account ADMINISTRATOR however is disabled by global company policy.

So if I run the above from a CMD box that was "run as administrator" it's working fine.
My question is: How can I run the same command from the Deployment screen in LANsweeper with these elevated permissions?

Kind regards
chrism010
#1chrism010 Member Posts: 2  
posted: 7/10/2019 3:22:47 PM(UTC)
Have you tried just running as system account? Thats what i run most of our deployments on since its basically god mode on computer.
Esben.D
#2Esben.D Member Administration Posts: 1,976  
posted: 7/12/2019 8:51:05 AM(UTC)
System account might indeed work.
Ramezi
#3Ramezi Member Posts: 6  
posted: 7/15/2019 3:49:15 PM(UTC)
Just curious how were you able to get this to script to install the complete 3.5 .net framework on a Win10, without any error messages.... error: 0x800F0906, 0x800F081F, 0x800F0907...
Using this script...
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart

Im running into errors listed above running it in PowerShell and CMD elevated...

Thank you..TCI

Active Discussions

Lansweeper Uninstall Software - Mozilla Firefox
by  Carl_Allen   Go to last post Go to first unread
Last post: Yesterday at 10:44:36 AM(UTC)
Lansweeper Installation Parameters
by  PeterG  
Go to last post Go to first unread
Last post: 1/8/2020 10:11:51 PM(UTC)
Lansweeper embedded questions
by  mkergan   Go to last post Go to first unread
Last post: 12/20/2019 5:19:46 PM(UTC)
Lansweeper Result: Deployment ended: The environment is incorrect.
by  mkergan  
Go to last post Go to first unread
Last post: 12/19/2019 6:31:44 PM(UTC)
Action Dameware Remote Support tool
by  Jaimee Sellers   Go to last post Go to first unread
Last post: 12/18/2019 4:14:18 PM(UTC)
Lansweeper Number Of Application Hang Event ID 1002 Count , Null
by  HRS  
Go to last post Go to first unread
Last post: 11/29/2019 9:42:49 PM(UTC)
Action Change Windows domain PC Name
by  DaveDischord   Go to last post Go to first unread
Last post: 11/27/2019 10:36:02 PM(UTC)
Lansweeper LsRemote.exe Background Image Removal
by  Martin Frey  
Go to last post Go to first unread
Last post: 11/27/2019 11:40:23 AM(UTC)