Notification

Icon
Error

dotNET framework 3.5 deployment

Posted: Monday, July 1, 2019 10:33:03 AM(UTC)
TCI

TCI

Member Original PosterPosts: 3
0
Like
On each version update of Windows we face a similar challenge d'oh!
We created a command to install the .NET 3.5 in Windows 10 v 1906.

Quote:
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart


On Windows v1809 this was still working.
However on v1906 the deployment fails due to lack of elevated permissions.
We always install with Scanning Credentials as this account is also local admin on all assets however
it seems DISM requires the NAME administrator for these elevated permissions.
The default account ADMINISTRATOR however is disabled by global company policy.

So if I run the above from a CMD box that was "run as administrator" it's working fine.
My question is: How can I run the same command from the Deployment screen in LANsweeper with these elevated permissions?

Kind regards
chrism010
#1chrism010 Member Posts: 2  
posted: 7/10/2019 3:22:47 PM(UTC)
Have you tried just running as system account? Thats what i run most of our deployments on since its basically god mode on computer.
Esben.D
#2Esben.D Member Administration Posts: 1,895  
posted: 7/12/2019 8:51:05 AM(UTC)
System account might indeed work.
Ramezi
#3Ramezi Member Posts: 6  
posted: 7/15/2019 3:49:15 PM(UTC)
Just curious how were you able to get this to script to install the complete 3.5 .net framework on a Win10, without any error messages.... error: 0x800F0906, 0x800F081F, 0x800F0907...
Using this script...
dism /online /loglevel:4 /Add-Package /PackagePath:"\...\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart

Im running into errors listed above running it in PowerShell and CMD elevated...

Thank you..TCI

Active Discussions

Lansweeper Vmware Vcenter and Hosts not scanning
by  pkamacho   Go to last post Go to first unread
Last post: Today at 8:33:17 PM(UTC)
Lansweeper Helpdesk Ticket "On-Hold"
by  Chris1052  
Go to last post Go to first unread
Last post: Today at 7:44:01 PM(UTC)
Lansweeper SNMPv3 Scanning of Cisco Devices
by  Bruce.B   Go to last post Go to first unread
Last post: Today at 7:40:08 PM(UTC)
Lansweeper Object reference not set to an instance of an object
by  Bruce.B  
Go to last post Go to first unread
Last post: Today at 6:33:18 PM(UTC)
Lansweeper New Exchange server feature scanning
by  Thomas D.   Go to last post Go to first unread
Last post: Today at 5:00:51 PM(UTC)
Lansweeper AD Users and email
by  CyberCitizen  
Go to last post Go to first unread
Last post: Today at 12:40:54 AM(UTC)
Lansweeper Distrubution Center workstation Map
by  CGIMana79   Go to last post Go to first unread
Last post: Yesterday at 6:00:44 PM(UTC)
Lansweeper Starting ticket # for helpdesk
by  AEM IT  
Go to last post Go to first unread
Last post: Yesterday at 5:17:22 PM(UTC)