Notification

Icon
Error

Lansweeper warnings sent to an email

Posted: Tuesday, June 25, 2019 2:23:29 PM(UTC)
MilicaM

MilicaM

Member Original PosterPosts: 6
0
Like
Hi,

I have an alert displayed on Lansweeper web console: "License Warning | Your license is limited to 5000 assets. You've reached 95%".

Is there a possibility to receive this warning over an email? And when the assets count is below 95% no email warning is received.

Thank you,
Milica
Esben.D
#1Esben.D Member Administration Posts: 1,738  
posted: 7/12/2019 9:55:15 AM(UTC)
You could create a report about it and use it in a report alert:

Code:
Select Top 1000000 Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) As
  [%]
From tblAssets
  Left Join (Select tblAssets.AssetID
      From tblAssets
        Inner Join tblAssetCustom On tblAssets.AssetID = tblAssetCustom.AssetID
        Inner Join tsysAssetTypes On tsysAssetTypes.AssetType =
          tblAssets.Assettype
        Inner Join tblState On tblState.State = tblAssetCustom.State
      Where tblState.Statename != 'monitor') As SQ1 On SQ1.AssetID =
    tblAssets.AssetID
Having Cast(Count(SQ1.AssetID) * 100.0 / 5000 As Decimal(10,2)) >= 95
MilicaM
#2MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:07:02 AM(UTC)
Hi Esben,

Many thanks for your reply!

I already found solution:

Select Top 1000000 Count(tblAssets.AssetID) As [Asset count],
5000 As [Asset limit],
Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As decimal(8,2)) As
[% used]
From tblAssets
Where tblAssets.AssetUnique Not Like 'Mon:%'
Having Cast(Cast(Count(tblAssets.AssetID) As float) / 5000 * 100 As
decimal(8,2)) >= 95

Where 5000 is asset limit.

Regards,
Milica
Esben.D
#3Esben.D Member Administration Posts: 1,738  
posted: 7/12/2019 10:16:37 AM(UTC)
You will still have to take into account that Monitor assets are not counted towards the license. So you will have to slightly adjust your report.
MilicaM
#4MilicaM Member Original PosterPosts: 6  
posted: 7/12/2019 10:36:44 AM(UTC)
Hey Esben, thanks for noticed it, but I already put the filter with:

Where tblAssets.AssetUnique Not Like 'Mon:%' :)

Milica

Active Discussions

Lansweeper Uptime incorrect
by  CyberCitizen   Go to last post Go to first unread
Last post: Today at 1:29:08 AM(UTC)
Lansweeper Lansweeper Not Saving New Asset
by  Terry1337   Go to last post Go to first unread
Last post: 7/19/2019 3:52:51 PM(UTC)
Lansweeper Email configuration
by  Ian.Prentice  
Go to last post Go to first unread
Last post: 7/19/2019 3:14:04 PM(UTC)
Lansweeper InTune Scanning not showing all devices
by  TBRIT   Go to last post Go to first unread
Last post: 7/19/2019 3:12:03 PM(UTC)
Lansweeper Unique Custom Fields
by  Hendrik.VE  
Go to last post Go to first unread
Last post: 7/19/2019 11:52:35 AM(UTC)
Lansweeper Lansweeper Remote Screenshot Folder
by  Esben.D   Go to last post Go to first unread
Last post: 7/19/2019 10:24:31 AM(UTC)
Lansweeper Lansweeper Enterprise optional?
by  Esben.D  
Go to last post Go to first unread
Last post: 7/19/2019 10:00:22 AM(UTC)