Notification

Icon
Error

User association report query - List all Active Directory users that don't have an asset of type X associated

Posted: Monday, June 24, 2019 5:38:51 PM(UTC)
dan508

dan508

Member Alpha Tester Original PosterPosts: 3
0
Like
Hi all.
slowly learning SQL, and I need a bit of assistance on this one query.
I want to query all Active directory users that don't have an asset of type 909 assigned to them. To do this, I have the following script, but it isn't working :(

select username
from tblADusers
where not exists
(select tbladusers.username
,tblAssetUserRelations.AssetID
,tblassets.Assettype

from tblADusers
inner join tblassetuserrelations on tbladusers.username=tblassetuserrelations.username
inner join tblAssets on tblAssetuserrelations.AssetID=tblAssets.AssetID
where tblassets.assettype =909
)


If I run the sub Query, it pull in all AD users that do have asset type 909 assigned to them. so shouldn't it be as simple as running a query to pull the user that aren't in the sub query?

Any help will be appreciated.

Thanks in advanceBrick wall ,
Dan
endyk
#1endyk Member Posts: 24  
posted: 6/26/2019 9:47:25 PM(UTC)
Hello Dan,

I think this should do it for you.

SELECT tbladusers.username,
tblAssetUserRelations.AssetID,
tblassets.Assettype
FROM tblADusers
INNER JOIN tblassetuserrelations ON tbladusers.username=tblassetuserrelations.username
INNER JOIN tblAssets ON tblAssetuserrelations.AssetID=tblAssets.AssetID
WHERE tblassets.assettype <> 909

Active Discussions

Lansweeper Unable to send to External Email
by  pryan67   Go to last post Go to first unread
Last post: Yesterday at 8:21:01 PM(UTC)
Lansweeper Lansweeper assets not being Scanned
by  Jordan  
Go to last post Go to first unread
Last post: Yesterday at 6:42:22 PM(UTC)
Lansweeper Database size growing too large
by  bladd   Go to last post Go to first unread
Last post: Yesterday at 4:26:44 PM(UTC)
Lansweeper Searching Specific File
by  mzipperer  
Go to last post Go to first unread
Last post: Yesterday at 4:23:29 PM(UTC)
Lansweeper Exchange 2010 information is not populating
by  Moe   Go to last post Go to first unread
Last post: Yesterday at 12:30:38 PM(UTC)
Lansweeper Routinely Exploited Vulnerabilities Query Report
by  pryan67  
Go to last post Go to first unread
Last post: Yesterday at 12:25:31 PM(UTC)
Lansweeper Creating a report for new devices every 2 hours to alert
by  Moe   Go to last post Go to first unread
Last post: 6/4/2020 7:26:11 PM(UTC)
Lansweeper Changes in the licensing model
by  BullGates  
Go to last post Go to first unread
Last post: 6/4/2020 6:27:23 PM(UTC)