Notification

Icon
Error

Add Document as File Link

Posted: Tuesday, June 18, 2019 10:11:32 AM(UTC)
mowo

mowo

Member Original PosterPosts: 3
0
Like
This issue has been solved! Click here to view the solution
Is it possible to add a document to an asset as a file link?

Instead of uploading the document to the IIS server we would like to just have a file link to our file server. Doing so we could keep the directory structure and retain access to the files for other usage.
Esben.D
#1Esben.D Member Administration Posts: 1,768  
posted: 6/19/2019 9:49:14 AM(UTC)
You can use a hyperlink custom field. In configuration\asset pages, you can configure the custom fields name and type. Then you can edit the assets and add the link to the document.
mowo
#2mowo Member Original PosterPosts: 3  
posted: 6/19/2019 10:28:33 AM(UTC)
This is working but the downside is that the link is very long and percent-encoded which makes it difficult to read. Would be great if documents could also be added as file links or if we could specify a display name for the custom field hyperlink.
AZHockeyNut
#3AZHockeyNut Member Alpha Tester Posts: 231  
posted: 6/19/2019 3:18:49 PM(UTC)
mowo, it could be done as in a UNC path (\\server\share) however, the problem is the context under which the application tries to open the file. you might then get into delegation issues etc. Also, as the app transitions to the cloud eventually like everything else seems to, opening those would be much more challenging.
I feel your pain as I wanted to do something similar.
mowo
#4mowo Member Original PosterPosts: 3  
posted: 6/26/2019 2:00:25 PM(UTC)
Using custom hyperlink fields with a file link and a UNC path (e.g. "file://server\dir A\dir B\file.pdf") can be used as a workaround for assets. However, this is not working for e.g. software licenses. Those entries support the upload of documents but don't have custom fields. Would really appreciate if file links would be supported somehow.

Active Discussions

Lansweeper how to add windows and office licenses manually.
by  cesar.ti   Go to last post Go to first unread
Last post: 8/23/2019 7:32:10 PM(UTC)
Lansweeper User roles and permissions
by  RKCar  
Go to last post Go to first unread
Last post: 8/23/2019 6:23:38 PM(UTC)
Lansweeper Deployment condition
by  RKCar   Go to last post Go to first unread
Last post: 8/23/2019 4:07:30 PM(UTC)
Lansweeper HP Printer not showing correctly
by  JacobH  
Go to last post Go to first unread
Last post: 8/23/2019 1:32:54 PM(UTC)
Lansweeper Moving Assets in Location not Saving
by  brodiemac   Go to last post Go to first unread
Last post: 8/23/2019 12:23:04 PM(UTC)
Lansweeper Scanning includes IOS devices even though I exclude them??
by  steveb  
Go to last post Go to first unread
Last post: 8/22/2019 11:05:33 PM(UTC)
Lansweeper lsagent not scanning/sending when using relay
by  Esben.D   Go to last post Go to first unread
Last post: 8/19/2019 12:31:02 PM(UTC)
Lansweeper Check if Netbios is disabled over TCP/IP
by  TaherMD  
Go to last post Go to first unread
Last post: 8/19/2019 6:00:51 AM(UTC)